Question Why isn't my port forward working

Jul 16, 2019
I have tried to port forward a port (25565) and got all details correct. I got my ip from ipconfig in the cmd (the ipv4). After I put in my port forward and enabled it, I went to canyouseeme to test if it worked, as I have has issues in the past. Suprise! It didn't work. Now I don't know if this has anything to do with it but the ipv4 (the one in cmd and on the router management site) is DIFFERENT then the one when I goto any of the "whats my ip" sites and canyouseeme. The one I got from cmd is the one I put in the port forward. I then tried to put in the ip from whatmyip and it said "The IP Address and the LAN IP Address should be in the same subnet." Ok, no big deal. Go over to my lan ip address and attempt to change the LAN subnet to MY ip address's Subnet, but it said the subnet should be different then the WAN IP Address. I do not get networking stuff and never really got a chance to learn it, can you help me solve this issue. I have a TP-Link Router and use Fibersphere at my ISP.


What is the IP address of the computer to which you wish to port forward?

Does that computer have a Static IP address reserved for it (via the computer's MAC) with that Static IP address being outside of the available DHCP IP address range?

To do so requires admin access to the network router. Do you have admin access to the router?

Perhaps there is some confusion between public IP addresses and private IP addresses?