Question why my athlon x4 840 no display

Oct 6, 2022
6
0
10
0
i have a problem to my pc i upgrade my cpu amd a4-6300 to athlon x4 840
the problem is after i put the new cpu it has no display its only working if i put my old cpu amd a4-6300
what should i do???
my specs:

motherboard Gigabyte fm2+

8gb ram dual slot 1600mhz

Gpu GT630 2GB
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Did you make sure your motherboard is on the latest BIOS version prior to the CPU upgrade? When you upgraded your APU to the discrete CPU, did you also drop in a discrete GPU to your build? The X4 840 doesn't have an iGPU.

motherboard Gigabyte fm2+
That doesn't tell us much about your motherboard's mode apart from the fact that it's made by Gigabyte. Please pass on the model of your motherboard.

Please list your specs to your build like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:
 
Oct 6, 2022
6
0
10
0
Welcome to the forums, newcomer!

Did you make sure your motherboard is on the latest BIOS version prior to the CPU upgrade? When you upgraded your APU to the discrete CPU, did you also drop in a discrete GPU to your build? The X4 840 doesn't have an iGPU.

motherboard Gigabyte fm2+
That doesn't tell us much about your motherboard's mode apart from the fact that it's made by Gigabyte. Please pass on the model of your motherboard.

Please list your specs to your build like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:
Welcome to the forums, newcomer!

Did you make sure your motherboard is on the latest BIOS version prior to the CPU upgrade? When you upgraded your APU to the discrete CPU, did you also drop in a discrete GPU to your build? The X4 840 doesn't have an iGPU.

motherboard Gigabyte fm2+
That doesn't tell us much about your motherboard's mode apart from the fact that it's made by Gigabyte. Please pass on the model of your motherboard.

Please list your specs to your build like so:
i forgot to place the specs
CPU: a4 6300 now upgrading to athlon x4 840
Motherboard: Gigabyte fm2+ GA-F2A68HM-S1 with a BIOS American Megatrends INC.FC 24/12/2015
Ram: 8GB DUAL SLOT 1600MHZ
SSD/HDD: SSD 120GB HDD 320GB
GPU: PALIT GT630
PSU: TRUE RATED 500WATS KOREAN BRAND(DONT KNOW HOW TO READ KOREAN HAHA)
Chassis : STANDARD
OS: WINDOWS 10 PRO 64BIT
Monitor: acer EB192Q
 
Oct 6, 2022
6
0
10
0
Where exactly have you connected the monitor?
Make sure to plug it into the graphics card's video out and not the one from the motherboard.
I plug it to my graphics card port it has a 3 display ports VGA,HDMI,DVI i use VGA bcause that is my only monitor connector i have
 

ASK THE COMMUNITY

TRENDING THREADS