[SOLVED] why my computer starts in uefi?

Oct 25, 2020
7
1
20
1
i built a new computer with an asrock a320m-hdv r4.0 motherboard. i have already installed windows on it, but when i turn it on, it always goes to the bios. once in the bios/uefi menu i exit, without changing anything, and it boot into windows.

whats wrong? why does it always go straight to the bios/uefi menu when i turn it on?
 

Karadjgne

Titan
Ambassador
In bios, Disable fastboot option. Then look in the boot order and make sure the system disk/ssd is default first in line. Sometimes if USB is set first, it'll detect something you have plugged in that uses software and gets confused because fastboot skips a lot of info and only boots according to cmos, which got saved when you shut down.
 
Reactions: Barty1884
Oct 25, 2020
7
1
20
1
In bios, Disable fastboot option. Then look in the boot order and make sure the system disk/ssd is default first in line. Sometimes if USB is set first, it'll detect something you have plugged in that uses software and gets confused because fastboot skips a lot of info and only boots according to cmos, which got saved when you shut down.
Yes, the fastboot option was always disabled. just like safe mode. The boot order doesnt appear directly in the uefi, I have to press f11 for the boot devices to appear. And still they are in the correct order, (because after exiting the uefi it enters windows10). (sorry for not writing well. english is not my native language)
 

ASK THE COMMUNITY