Question Why when i disable C-States in bios the frequency of my processor is limited to 4800mhz?

Aug 13, 2021
34
0
30
0
Why when i disable C-States in bios the frequency of my processor is limited to 4800mhz? because when C-States is enable i got 5100mhz ~ 5200mhz in full use.

If u asking why i disabled the C-States option is because my system randomly crash.

thank you

Monitor 165Hz Gamer 27" Dell S2721DGF
Intel® Core™ i9-11900K Processor 16M Cache, up to 5.30 GHz
VENGEANCE® RGB PRO 32GB (4 x 8GB) DDR4 DRAM 3200MHz C16 - CMW16GX4M2D3000C16 Same Serie for all 4 sticks
RTX 3070ti Suprim X MSI - 8gb
Corsair RM850 PC Power Supply Unit 850W 80PLUS Gold
CUE H150i ELITE CAPELLIX (360mm)
Kingston SSD A2000 1000GB 1TB M.2 2280 NVMe PCIe
Windows 11 (Build 1000.22000.739.0)
 
Why when i disable C-States in bios the frequency of my processor is limited to 4800mhz? because when C-States is enable i got 5100mhz ~ 5200mhz in full use.

If u asking why i disabled the C-States option is because my system randomly crash.

thank you

Monitor 165Hz Gamer 27" Dell S2721DGF
Intel® Core™ i9-11900K Processor 16M Cache, up to 5.30 GHz
VENGEANCE® RGB PRO 32GB (4 x 8GB) DDR4 DRAM 3200MHz C16 - CMW16GX4M2D3000C16 Same Serie for all 4 sticks
RTX 3070ti Suprim X MSI - 8gb
Corsair RM850 PC Power Supply Unit 850W 80PLUS Gold
CUE H150i ELITE CAPELLIX (360mm)
Kingston SSD A2000 1000GB 1TB M.2 2280 NVMe PCIe
Windows 11 (Build 1000.22000.739.0)
Just what I see.
With C states disabled it seems to lock the cpu to all core turbo speed.

On the downside the cpu runs a little hotter.
On the up side the machine perf is a little better.

Run your own test and see which way is better for the stuff you run.
 
Reactions: AlltaiRMentoR
Aug 13, 2021
34
0
30
0
thank you for answering. but i very bored about this because if i active the c-states my system cause random freeze. i try everything like disable xmp profile and other question but only disabling the c-states solve my problem
 

uWebb429

Respectable
May 22, 2020
539
161
2,640
107
Since the Core i was introduced in 2008, the C states have been getting blamed for stability problems. The real problem is when you enable the C states, the CPU runs faster when lightly loaded.

What sort of stability testing have you done? Are you using the default BIOS settings for voltages? Are you full load stable? Do these issues only happen when lightly loaded? Can you run Cinebench R23 for 10 minutes without crashing?

A lot of people buy a collection of random parts, set the BIOS to default settings and expect that their new computer will run trouble free. That rarely happens. It can take a lot of testing and a lot of adjustments before a new computer will run like it should be able to run.

What motherboard are you using? For future reference, it is usually easier to get 2 x 16 GB memory modules to run stable compared to 4 x 8 GB memory modules.

For desktop computers, I prefer to lock the CPU to a single speed. I find it is a lot easier to come up with a stable system by doing this. You can set all of the turbo ratios in the BIOS to the same value and then in Windows you can use the High Performance power plan.

Some people think that having a computer run at full speed when it is idle or lightly loaded is a terrible thing to do. It is OK to do this if the core C states are enabled. You can have a fast computer, excellent stability and low idle power consumption, all at the same time.

For my 10850K, I decided to run it at a steady 5000 MHz. At default settings the 10850K can run at up to 5.20 GHz when lightly loaded. I decided to decrease the maximum CPU speed so I could reduce the peak voltage. The default full load speed is 4.80 GHz so I bumped that up to 5.00 GHz. Some users are shocked to see that power consumption and the CPU idle temperature is excellent when running at full speed. It sips power like a notebook.



The individual cores are averaging over 99% of the time in the low power C7 state. In this state the cores are sitting dormant at 0 volts and they are disconnected from the internal clock so they are sitting at 0 MHz. That is why idle power consumption is excellent.



I would start by thoroughly testing your computer with the C states disabled. You want to be 100% stable when fully loaded or lightly loaded. Then you can enable the core C3 state in the BIOS and see how that goes and then enable the core C7 state.

You can leave the package C states disabled. I have package C2 and package C3 enabled. The core C states are the important ones. A stable computer should still be stable when the core C states are enabled.

If you are still having issues, run HWiNFO and post some screenshots of your voltages. It can take some voltage tweaks to the SA and IO voltages to try and get stable. You might also have to pull two memory sticks to see if maybe your memory is causing your stability issue.
 
Intel turbo boost on non K series CPUs or on non Z series motherboards have always required that the C states are enabled.

You can bypass this requirement if you have both a Z series board and K series CPU.


That is normal.
I don't have a K or a Z and I don't use C states.
The machine runs fine.
I did not realize the machine is busted.
Thanks for that.
 
Aug 13, 2021
34
0
30
0
System crashes when C-states are enabled, but not when disabled?
:unsure:

To me, it sounds like an unstable overclock was applied.
What's the motherboard?
Maybe but i'm using Intel Turbo Boost Max only for OC (only enabled) on bios option.

My motherboard model Z590-F Gaming Wifi

Thank you
 
Aug 13, 2021
34
0
30
0
Since the Core i was introduced in 2008, the C states have been getting blamed for stability problems. The real problem is when you enable the C states, the CPU runs faster when lightly loaded.

What sort of stability testing have you done? Are you using the default BIOS settings for voltages? Are you full load stable? Do these issues only happen when lightly loaded? Can you run Cinebench R23 for 10 minutes without crashing?

A lot of people buy a collection of random parts, set the BIOS to default settings and expect that their new computer will run trouble free. That rarely happens. It can take a lot of testing and a lot of adjustments before a new computer will run like it should be able to run.

What motherboard are you using? For future reference, it is usually easier to get 2 x 16 GB memory modules to run stable compared to 4 x 8 GB memory modules.

For desktop computers, I prefer to lock the CPU to a single speed. I find it is a lot easier to come up with a stable system by doing this. You can set all of the turbo ratios in the BIOS to the same value and then in Windows you can use the High Performance power plan.

Some people think that having a computer run at full speed when it is idle or lightly loaded is a terrible thing to do. It is OK to do this if the core C states are enabled. You can have a fast computer, excellent stability and low idle power consumption, all at the same time.

For my 10850K, I decided to run it at a steady 5000 MHz. At default settings the 10850K can run at up to 5.20 GHz when lightly loaded. I decided to decrease the maximum CPU speed so I could reduce the peak voltage. The default full load speed is 4.80 GHz so I bumped that up to 5.00 GHz. Some users are shocked to see that power consumption and the CPU idle temperature is excellent when running at full speed. It sips power like a notebook.



The individual cores are averaging over 99% of the time in the low power C7 state. In this state the cores are sitting dormant at 0 volts and they are disconnected from the internal clock so they are sitting at 0 MHz. That is why idle power consumption is excellent.



I would start by thoroughly testing your computer with the C states disabled. You want to be 100% stable when fully loaded or lightly loaded. Then you can enable the core C3 state in the BIOS and see how that goes and then enable the core C7 state.

You can leave the package C states disabled. I have package C2 and package C3 enabled. The core C states are the important ones. A stable computer should still be stable when the core C states are enabled.

If you are still having issues, run HWiNFO and post some screenshots of your voltages. It can take some voltage tweaks to the SA and IO voltages to try and get stable. You might also have to pull two memory sticks to see if maybe your memory is causing your stability issue.
Your explanation is fascinating I really believe the problem is instability. But I have doubts if only with Intel Turbo Boost Max can it occur from settings that are not adaptable to my configuration?

The issue happens in idle mode or some times playing some game where use so much my CPU. I never tried Cinebench R23 test i will do that.


HWMonitor this moment:







I try again test stability with c-states enabled is that you see in screenshot overclok around 5000mhz.

my motherboard model Z590-F Gaming Wifi (i don`t find other states option in bios like C3, C6 ..... only c-states option).

thank you
 
Last edited:

uWebb429

Respectable
May 22, 2020
539
161
2,640
107
When your computer is idle at the desktop, on the main screen, what does ThrottleStop show for C0%? What does the C states window report for AVG CPU usage? My screenshot shows the cores are spending 99% of the time in C7. Your screenshot above shows an average of only 39.2%. Open the Task Manager, go to the Details tab and find out what is running in the background on your computer.

Use ThrottleStop to change to the Windows High Performance power plan so your CPU runs at a consistent speed. Show a screenshot of the FIVR window. You can use ThrottleStop to adjust the turbo ratios so your CPU runs at a fixed and consistent speed.

At default settings, Windows 11 turns on a lot of virtualization features that can interfere with maximum performance. The FIVR window will show if this is a problem for your computer.

I did not realize the machine is busted.
Your machine is not busted. Intel CPUs need to have the C states enabled so Intel Turbo Boost works correctly.
 
Aug 13, 2021
34
0
30
0
When your computer is idle at the desktop, on the main screen, what does ThrottleStop show for C0%? What does the C states window report for AVG CPU usage? My screenshot shows the cores are spending 99% of the time in C7. Your screenshot above shows an average of only 39.2%. Open the Task Manager, go to the Details tab and find out what is running in the background on your computer.

Use ThrottleStop to change to the Windows High Performance power plan so your CPU runs at a consistent speed. Show a screenshot of the FIVR window. You can use ThrottleStop to adjust the turbo ratios so your CPU runs at a fixed and consistent speed.

At default settings, Windows 11 turns on a lot of virtualization features that can interfere with maximum performance. The FIVR window will show if this is a problem for your computer.


Your machine is not busted. Intel CPUs need to have the C states enabled so Intel Turbo Boost works correctly.

Can you explain to me how to enable the options because I only know how to open ThrottleStop haha. I checked my task manager and in the details tab there are many processes running in the background.

and here are my FIVR window screenshot.

 
Last edited:

uWebb429

Respectable
May 22, 2020
539
161
2,640
107
there are many processes running in the background
What does ThrottleStop report for idle C0%? That is the important number to watch. Windows has lots and lots of background tasks running. They may use up some memory but most of them are not putting any significant load on the CPU.

Task Manager reports System Idle Process at 99%. That means when my computer is idle, it truly is idle. If you have piles of background tasks always randomly loading your CPU, this can interfere with smooth game play and smooth everything.



If you want to try using ThrottleStop to run your CPU at a fixed speed, adjust all of the FIVR - Turbo Ratio Limits to the same value. Start by setting them all to 48. If you are stable, try increase them all to 49 or 50.

If you want to use any turbo ratios that are higher than the default turbo ratios that are listed, you will need to check the Overclock box.
 
Last edited:
Aug 13, 2021
34
0
30
0
What does ThrottleStop report for idle C0%? That is the important number to watch. Windows has lots and lots of background tasks running. They may use up some memory but most of them are not putting any significant load on the CPU.

Task Manager reports System Idle Process at 99%. That means when my computer is idle, it truly is idle. If you have piles of background tasks always randomly loading your CPU, this can interfere with smooth game play and smooth everything.



If you want to try using ThrottleStop to run your CPU at a fixed speed, adjust all of the FIVR - Turbo Ratio Limits to the same value. Start by setting them all to 48. If you are stable, try increase them all to 49 or 50.

If you want to use any turbo ratios that are higher than the default turbo ratios that are listed, you will need to check the Overclock box.
my value changes from 90 to 99 the idle mode in the process task manager this is fine?
i tried to fix all cores in 50 on ThrottleStop this is right mode to oc? thank you

 

uWebb429

Respectable
May 22, 2020
539
161
2,640
107
my value changes from 90 to 99
My computer spends most of its idle time at 99. Most people think that 90% is pretty good but with an 8 core CPU, that is almost one entire core being used up processing background tasks. Look in the Task Manager Details tab and look in the Resource Monitor to see if everything that is running in the background is necessary. When performance is not smooth, looking for rogue tasks is a good place to start troubleshooting.

Your FIVR screenshot shows that you set the Turbo Ratio Limits to values higher than the listed default values. Usually you need to check the Overclock box in this section for this to work properly. Running the 50 multiplier instead of the 48 multiplier when 8 cores are active is overclocking.
 
Aug 13, 2021
34
0
30
0
My computer spends most of its idle time at 99. Most people think that 90% is pretty good but with an 8 core CPU, that is almost one entire core being used up processing background tasks. Look in the Task Manager Details tab and look in the Resource Monitor to see if everything that is running in the background is necessary. When performance is not smooth, looking for rogue tasks is a good place to start troubleshooting.

Your FIVR screenshot shows that you set the Turbo Ratio Limits to values higher than the listed default values. Usually you need to check the Overclock box in this section for this to work properly. Running the 50 multiplier instead of the 48 multiplier when 8 cores are active is overclocking.
I ran the oc without checking the box Overclock could it have damaged my processor?
 
Aug 13, 2021
34
0
30
0
No.

It will either work at the speed you have requested or it will not work. Some CPUs need to have that box checked so they can run at full speed while others do not.

It is pretty hard to damage an Intel CPU. They are well protected from almost anything a user can throw at them.
i actived Overclock option and set all cores to 50 with c-states enabled. i will test the stability in all % usage of cpu and idle situation. thank you for helping me
 

ASK THE COMMUNITY