[SOLVED] Why won't my Windows 10 PC go to sleep automatically?

CrimsonKnight98

Reputable
Apr 21, 2015
32
1
4,535
0
I have it set to go to sleep after a minute (for testing purposes) and it will not go to sleep! The monitor turns off but the computer won't turn off. I have messed with power settings and disabled the "prevent idle" setting under multimedia power options. I did a command prompt powercfg /requests with nothing coming up as preventing sleep. Finally, I did a powercfg -energy which came up with 6 errors but I do not understand what to do with the information it provided (also none of the errors told me the system was being help back from idling). Anyone know what to do?

Here's a link to the energy report that turned up 6 errors: https://drive.google.com/file/d/1WV8tZOeHP4IbLkcZmgEa9-Vly5Ky-_6M/view?usp=sharing

SOLUTION: An audio manging software I use called Voicemeeter prevented my computer from sleeping when it was active. A clean boot was the general solution, in other words, clean booting was the way I was able to find the program causing the issue. THANK YOU TO EVERYONE WHO HELPED!
 
Last edited:

CrimsonKnight98

Reputable
Apr 21, 2015
32
1
4,535
0
Windows 10 Home 64Bit Build 17134
CPU: Intel i7 7700K
GPU: Nvidia GTX 1060 6GB
Motherboard: ASUS PRIME Z270-A
RAM: 8GB

Hibernation is disabled

I ran the troubleshooter. No issues detected.

Also, this is not a new issue. It has been going on for more than a year now but I never thought of doing anything about it until now.
 

Darkbreeze

Titan
Moderator
Try the solutions suggested here. It may or may not be relevant, but worth trying. Disabling hibernation and hybrid sleep are generally always the first go to solutions for sleep issues on windows 8.1 and 10, but there are other specific indications like power settings for individual devices in device manager that can cause similar problems as well.

 

Darkbreeze

Titan
Moderator
Ok, so let's start with the basics then.

First, I'd make sure you have the MOST recent BIOS version installed, which for your board would be version 1302 available here:


If you do not have BIOS version 1302 installed, it would be HIGHLY advisable that you do so.

Next, I would recommend updating to the latest Windows build version, since you are not on the current one.

https://www.microsoft.com/en-us/software-download/windows10

Then, make sure you have the latest Intel chipset drivers installed, which would be these, and are much newer than what is available from the motherboard product page.

https://downloadcenter.intel.com/download/28768/Intel-Chipset-Device-Software-INF-Update-Utility-?product=98089


Next, I would install ALL of these, which are motherboard specific drivers, if you do not know for certain that you have already installed these exact versions.

Realtek audio driver: https://dlcdnets.asus.com/pub/ASUS/mb/01AUDIO/Audio_6.0.1.8273_20171225.zip

Intel LAN driver: https://dlcdnets.asus.com/pub/ASUS/mb/04LAN/Intel_LAN_22.9.zip
 

jimmysmitty

Polypheme
Moderator
What power supply are you using?
And storage.

Beyond the USB errors, which may be preventing it, there is also this:

"PCI Express Active-State Power Management (ASPM) has been disabled due
to a known incompatibility with the hardware in this computer."

Thats from his log and I would asume some piece of hardware using the PCIe lanes is causing that. Might be a NVMe SSD.
 
Reactions: Rogue Leader

Saga Lout

Olde English
Moderator
Have you tried turning off Hibernation? Run a Command form as Administrator and use the syntax
powercfg /hibernate off
then hit the Enter key. Restart the PC and see if it worked. It has been known to confuse Sleep settings.
 

Darkbreeze

Titan
Moderator
I don't know. Was about to get into that.

Well I did all that and I'm still unable to get my computer to sleep automatically. Any other ideas?
So, I'd try going into your device manager, open your network adapters and uncheck the wake on lan options that say "allow this device to wake the machine" blah blah blah, and then also go into the bios and disable the options for Wake On LAN. If there are any settings for your WiFi or LAN adapter in device manager in the device settings that are related to "magic packets", I'd disable those as well.
 

CrimsonKnight98

Reputable
Apr 21, 2015
32
1
4,535
0


Ok, that was a PS3, but you get the idea. LOL.

Seriously, I'm not sure what else to try. I'll bring in another member that might have some further ideas.
Sometimes I wish I could destroy my computer like that when it's acting up! Haha. Thank you for all your help! I appreciate it. :)


What power supply are you using?

An EVGA 500W W1 80+ White PSU.

And storage.

Beyond the USB errors, which may be preventing it, there is also this:

"PCI Express Active-State Power Management (ASPM) has been disabled due
to a known incompatibility with the hardware in this computer."

Thats from his log and I would asume some piece of hardware using the PCIe lanes is causing that. Might be a NVMe SSD.
I'm using both a Samsung 850 EVO 500GB 2.5" (MZ-75E500) as my primary drive and a Western Digital 1TB 5400RPM hard drive (don't remember the color) as my secondary/ large storage drive.

I don't know. Was about to get into that.



So, I'd try going into your device manager, open your network adapters and uncheck the wake on lan options that say "allow this device to wake the machine" blah blah blah, and then also go into the bios and disable the options for Wake On LAN. If there are any settings for your WiFi or LAN adapter in device manager in the device settings that are related to "magic packets", I'd disable those as well.
I did all the network adapter disabling and disabled wake on magic packet for ethernet (I'm using WiFi so I don't know if that makes a difference). I'll mess with the BIOS now.

I just checked the BIOS. All the power on by PCI-E and other power on settings are disabled.
 
Last edited:

CrimsonKnight98

Reputable
Apr 21, 2015
32
1
4,535
0
WAIT! SLEEP MODE IS WORKING!!!

False alarm, it still won't activate on its own. :( I can manually put the computer to sleep (I don't believe that worked before) but it still doesn't do it on its own.
 
Last edited:

Saga Lout

Olde English
Moderator
I came across a case like this a few years back. A man was playing games late into the night and his wife took remote control and turned the machine off whenever she thought he ought to give her and the children some attention instead.

Just sayin'.
 

Darkbreeze

Titan
Moderator
This is the opposite of that SL. In THIS case, he can't GET it to go to sleep automatically. It will sleep if he puts it to sleep, but it won't sleep on it's own.

Personally, I'd never set it up to sleep automatically anyhow, and I typically sleep the system every time I walk away from it if I plan to be gone more than five minutes because it only takes two seconds for it to resume, but obviously some people prefer it to do so automatically and I can understand that.
 

CrimsonKnight98

Reputable
Apr 21, 2015
32
1
4,535
0
Which Windows power plan are you currently set to? Balanced? Performance? Etc.

Double check everything here:


And I mean try all of it. Something there has to be relevant to your problem.
I'm on Balanced. Same as when it used to work.

Before I try all these solutions does it make sense that any of these could fix the issue I'm having where I can manually put the computer to sleep and it doesn't wake back up, but it will not go to sleep on its own?

Also, I can't change the settings in Windows UpdateOrchestrator (solution 8). My computer won't let me change the setting.

And yes, sometimes I walk away from the computer for a few hours unexpectedly and I would like it to go into a low-power state during that time. :(
 

CrimsonKnight98

Reputable
Apr 21, 2015
32
1
4,535
0
When all else that we would commonly try has failed, then yes, I'd say anything is worth trying if it's a legitimate suggestion that isn't based on throwing powdered unicorn poop at it. LOL.
I tried every solution except 8 and 9 since 8 I can't change and 9 requires me to have an HP computer it seems. Still no luck. The only thing I didn't try was unplugging my internal HDD to see if that is keeping the system on.

Any other ideas besides throwing unicorn feces at it?


It is working now!!
I tested it 4 times after using
powercfg -lastwake in Command Prompt which turned up with this. I do have a small fan that is connected to a USB port in the front so I tried unplugging it and seeing if my computer would sleep without it, it did after 1 minute and 30 seconds. Then I tried plugging it back in, and the computer also went to sleep but this time after 2 minutes and 50 seconds. I tried both ways again and I got the same times for both tests--1:30 without the fan and 2:50 with the fan. Now I'm wondering, why does having the fan attached make the system take the same amount of time longer to sleep and is there any way for me to prevent the fan from interfering (maybe having that port be ignored somehow)?

Now as for the cause: I am not 100% sure what caused this issue as it isn't the fan, however I do use a program called Voicemeeter which redirects audio channels. Also, it will come up as a program preventing system idle when doing a
powercfg -requests command, though tried to see if the system would sleep without it active before I posted the original question here, so it wasn't exclusively it preventing the computer from sleeping. I'll have to go back through that list and see what was causing it.
Anyway, since it is working now, is there a way to get this program to not prevent Windows from sleeping? I would hate to have to turn it off every time, I might as well just manually set the computer to sleep, defeating the purpose.

My questions: Why does the fan cause the system to take an exact interval longer to sleep and can this be changed?
Is there a way to stop Voicemeeter from disrupting my computer's sleep?
 
Last edited by a moderator:

Darkbreeze

Titan
Moderator
As per the developers of Voicemeeter, they apparently know there is a problem with sleep related to their program and I am not seeing any evidence that they have fixed the problem. I'd recommend looking for another program to do what you use voicemeeter for.

https://forum.vb-audio.com/viewtopic.php?t=403

As far as the fan goes, I've never heard of a fan causing a delay in sleep. What is the fan model and which header is it connected to? Does it do the same thing if you connect a DIFFERENT fan to that header?

Is that a case fan header? Which one? Does it do it if you connect that fan to a DIFFERENT header?

How many case fans do you have and what is your CPU cooler model?

In the BIOS, which of the available thermal sensors is assigned to be monitored for the control of that fan? There are usually several these days such as CPU, motherboard, VRM, PCH, T-sensor, etc.
 

CrimsonKnight98

Reputable
Apr 21, 2015
32
1
4,535
0
As per the developers of Voicemeeter, they apparently know there is a problem with sleep related to their program and I am not seeing any evidence that they have fixed the problem. I'd recommend looking for another program to do what you use voicemeeter for.

https://forum.vb-audio.com/viewtopic.php?t=403

As far as the fan goes, I've never heard of a fan causing a delay in sleep. What is the fan model and which header is it connected to? Does it do the same thing if you connect a DIFFERENT fan to that header?

Is that a case fan header? Which one? Does it do it if you connect that fan to a DIFFERENT header?

How many case fans do you have and what is your CPU cooler model?

In the BIOS, which of the available thermal sensors is assigned to be monitored for the control of that fan? There are usually several these days such as CPU, motherboard, VRM, PCH, T-sensor, etc.
Oh that's great news! I'm glad it's a Voicemeeter problem. That makes me feel better that it is a known issue.

And it's a small USB fan I bought at a dollar store it looks like this. Let me check the other info you requested.

I have 2 case fans on the front and on the back.
The CPU fan is a "be quiet! DARK ROCK PRO 3 Silentwings CPU Cooler 250W TDP"

But are you thinking I'm talking about a case fan causing the delay? It is just a standard USB fan I use to blow on me when I'm at my desk.
 
Last edited:

Darkbreeze

Titan
Moderator
If it's a USB fan, then you just need to figure out which USB controller it controls and in the device manager settings look at the power management tab for the specific USB hub or controller, and disable the setting that says "allow this device to wake the computer". It might take trial and error to figure out WHICH hub or controller that USB port is attached to in device manager.
 

ASK THE COMMUNITY

TRENDING THREADS