Question Wifi adapter turns off, no power managment tabs, registry trick not working

Jul 16, 2021
1
0
10
0
OK so as the title says.

I have a Dell XPS13 running Win 10 20h2 update and the wifi adapter turns off after x amount of time even plugged in.

I don't have any power management option in the device or elswhere. I tried the registry trick (adding a dword named "CsEnabled" and value 0) and nothing worked.

I did swap my killer adapter for an actual Intel one (killer adapters are garbage on their best day..) and I have the latest Intel version of the driver installed but...

I noticed that in the driver details I have 4 different locations for it? Also in the event, everytime I try to update the driver, it boots up saying the peripheral had an issue starting. I think I have one too many driver installed but I'm not sure. I could post a picture but I don't know which site you guy prefer for hosting...

I hope I gave enough juice to get some help from you people!
 

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Post pictures via imgur (www.imgur.com).

Stay out of the Registry. Registry edits are a last resort and the system and data must be fully backed up beforehand.

All too easy to brick the system with a typo or an inappropriate online "trick".
 

ASK THE COMMUNITY