Question WiFi and Local File Sharing Speeds on Laptop much slower than supported ?

May 1, 2021
I got a 100 Mbps fiber connection 2 days ago.
It came with a proprietary modem+router thing (does have a control panel i can access using
It works flawlessly on all devices however i have a speed issue on my laptop

On every other device in my home (phones smart tv's etc) the speed on both download and upload is 120 Mbps (tested on,, and google speed test and by downloading stuff off google drive)
However, on my 2 laptops with the same Qualcomm Atheros QCA61x4A wifi card the speed is a maximum of 40 Mbps it feels like it being artificially capped or something bcoz it never goes above that.
I have tried-
  1. Resetting everything network-related on both laptops (
  2. Changing the wireless mode on both laptops (
  3. Perform a clean boot on one laptop (
  4. Turning off WMM and Qos setting on my router, which btw resulted in laptop speeds remaining the same and the phones basically unable to do anything on the internet.(
I am using 5Ghz
and my laptop and router both support AC Wifi (WIfi 5) whose theoretical maximum is something like 700 mbps

However, nothing seems to work at all and I am still getting 40 Mbps on any speed testing site or even while downloading something
Heck my local file transfer between laptops using shared folders is literally 16-17 Mbps (very very slow)
and the weird thing is when I use my phone's hotspot as a wifi network to transfer files locally I get speeds of 200 Mbps or so regularly.
I have spent 2 nights troubleshooting this crap to no avail.

I need help.
If you look at the network properties for the wifi connection what connect speed does it show....this is actually a MCS value not so much a speed. How does this number compare to the laptop that works.

In optimum conditions you should see a number of 866 assuming your router support at least the same connection rate as your card.

This is a negotiated value and if it is lower it might for example indicate poor signal strength or something.