[SOLVED] Wifi cardbus cards won't connect to secure networks

onespeedbiker

Prominent
Apr 13, 2019
685
36
490
11
I have an old IBM R50 Thinkpad running XP sp3, that came without wireless wifi so I have been trying to get a pcmcia cardbus adapter cards BTW the onboard eithernet works graet. The first one I tried was a Netgear WG511 802.11b. I loaded the software, however the using the Netgear Wizard, I was unable to find any secure Networks, including my own that runs from an Xfinity router/modem. I have wireless connections to Xfinity wireless router with my Windows 10 PC, 2 android phones, and even another old laptop, Latitude D600 with an internal wifi adapter running XP .

Using the WG511 card, I uninstalled the software but kept the drivers, and tried to install them manually. This time windows showed all the available netwroks, but when I tried my wifi key I got an error that talked abot needing 40 bits or 400bits and special passwords .

Next I tried a SMC 802.11g bus card. Again I loaded the software, but again with the SMC utility software there were no networks to find. Again I uninstalled the software, safe the drivers and loaded the drivers manually, but this time it worked. Again the networks showed up but this time I was able to sign onto my network. All these are 54Mps and I would like to try a 108Mps adapter; the ones I have seen are 802.11g. I pretty sure the reason the utility software doean't work is becasue it is for small office networking and not for the Internet. I hoping since the SMC 54Mps 802.11g adapter worked, that a 108Mps 802.11g would also work. Still I'm wondering what the deal was with the 802.11b adapter. Is it simply the driver or some incompatibility issue? The WG511 even said it was upward compatible with 802.11g.
 
Last edited:
1. Your WIFI router may no longer support the very old 802.11b.

2. 802.11g 108m is often called 802.11g+ and again not all WIFI router supported it.

3. The 40 bit message is referring to an outdated encryption method, drivers too old.

Just get a modern USB dongle and be done with it.
 

ASK THE COMMUNITY