Question Wifi Connection Issues - Detailed Description Inside

Feb 26, 2020
2
0
10
0
Hello,

I am experiencing an infuriating issue and I'm at the end of knowing what to do to solve it.

The issue is:

About a week ago I changed my wireless modem to a TP-Link Archer C2 AC750 (I was previously using a Tp-link N600 wireless ADSL 2). This is because my ISP now provides faster internet which requires a WAN connection and no longer an ADSL 2 (phone line) connection. The Archer C2 I have also used previously before without any issues, when I lived in another city.

Currently, my laptop (windows 10, Asus K501u) can connect to the wifi and receive internet access without any problems. My mobile phone (android) can also connect, as can my partners and our TV. My desktop, however, can't hold a stable connection although it displays it's status as "Connected, Internet Access" - I often have websites drop or fail to load. I have a number of applications that require constant internet connection (part of their anti-piracy validation) and they cannot maintain a connection, even though the wireless says "connected, secured". Chrome usually displays a "DNS probed finished no internet" error message when pages fail to load. Sometimes the wireless signal will show "Connected, No Internet" also, but this is not consistent with whether I have a connection or not. When i swapped my Desktop's internet from the C2 to my Android Mobile phone as the hotspot, the issues went away (the applications also were able to maintain a constant connection). As soon as I connected back to my home wifi, the internet problems returned. Additionally, when trying to run speedtest on Ookla, I usually get an error message saying it "cannot connect potentially due to a firewall blocking it" or I receive "Latency Test Error". I have attempted with the windows firewall disabled, no luck.

My desktop is:

Windows 10
AMD 3700 - MSI x470
TP-Link Archer T4E AC1200 Wireless Dual Band PCI Express

I have tried:

-uninstalling and updating wireless card drivers
-flushing DNS and IP config in CMD (following instructions on Toms Hardware and other sites)
-changing power management settings
-specifying wireless mode (e.g. 802.11b/g/n and 802.11a/n/ac)
-unticking "look for other wireless networks while connected"
-restarting everything about 100 times
-factory reset of Archer C2
-"Network Reset" under Windows 10 Settings > Status
-disabled firewall, disabled windows defender


I've gone back and forth between whether it's an issue with my computer or my router. I've tried all my devices in the exact location as the Desktop's antenna to ensure it's not a black-spot of connection. I'm really stumped, and it's infuriating.

Please help if you know what I can do to fix this, I think I've followed every "fix wifi issues" list around, and not yet found a solution.
 
Feb 26, 2020
2
0
10
0
Thanks for the suggestion. Still no bueno unfortunately - I should note also, when I hotspotted from my mobile, I placed it in the same location as the router to try to replicate the same distance travelled by wifi, and the hotspot had no issues with the PC, it's only this router (but also no other device is having an issue with the router)
 

ASK THE COMMUNITY

TRENDING THREADS