"'Wifi' does not have a valid IP configuration"/"The default gateway is not available"

Dec 8, 2018
14
0
10
0
Three days ago my gaming pc encountered network issues and has been unable to connect to the internet, displaying either "'wifi' does not have a valid IP configuration" or "default gateway is unavailable" when I attempt to diagnose the issue with troubleshooter. I have no idea what could have caused this issue as I've never encountered it before. The troubleshooter changed the error after I attempted to change the "value" of my adapter from "disable" to "enable" via the properties of my wifi connection in Network and Sharing Center.

I have a USB wifi adapter that receives my signal and a wifi signal booster less than 2 feet from said adapter. My pc is recognizing our network and is connected, but has no internet. I have tried the standard approaches such as resetting both the modem and router, updating/uninstalling the driver for my wifi adapter, manually setting the IP address (if requested I can list them out), using the command prompt to enter in commands like "ipconfig /release," "ipconfig /renew," "netsh winsock reset," "netsh int ip reset," and others. I have also attempted other less common methods like assuring that the wired and WLAN autoconfig are both on automatic, changing the power setting modes of the adapter and even switching adapters. Through all of these, the problem persists.

For those who will propose a hardware issue, unless it is something like the brand being notoriously faulty/defective please refrain from simply suggesting I replace my adapter. I am 100% certain this is a software issue. I tried the adapter on my laptop and it worked just fine. However, the second I plug it back into my tower, nada. Same with my alternative wifi adapter. Please help, while this isn't an urgent issue, most of my pc's use is online gaming and important schoolwork.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS