Question WIFI Fluctuating at Consistent Rate

Jun 14, 2020
1
0
10
0
Hi All,

I recently did a PC upgrade and got a bunch of new parts. One of them being a new wireless Network adaptor. I have recently started to have major fluctuations in my internet speed. It was quite terrible before because my network adaptor was only able to pick up my 2.4 Ghz Channel, now with the 5Ghz channel it was going at the advertised speed for the first few days. Then a couple of days ago the connection started to 'draw tall mountains' in the Task Manager. With the advertised speed being 50MBPS Down and 20 MBPS up (Australian NBN) while I am doing anything internet related there is a major and consistent fluctuations from around 20MBPS-50MBPS (depending on the task) speed down to a complete 0kbps which has really killed my ability to play any games online (streaming stuff is still doable).

I have done a Speedtest (Ookla) on all my other devices namely a Samsung S9 and a HP Spectre x360 (OLED). Both of these devices have maintained the speed desired and advertised while my PC only keeps it up for a bout 3-5 seconds and then bottoms out and ramps back up to speed. Think of my internet fluctuations like the image below (not my internet connection just some random one found online) but it goes all the way down to zero and then ramps back up.

Solutions Attempted:
Restarted PC and modem/Turned off and on again :p
IPCONFIG flush
Installed all new Drivers for both TPLINK and Motherboard
Uninstalled and reinstalled the wireless adaptor
Forgot and reconnected to WIFI
Switched to both the 5Ghz (one that I am currently using) and 2.4Ghz Channels
Changed the DNS to 8.8.8.8 and second 8.8.4.4 and then reverted back to auto


PC SPECS:
CPU: Intel i5 9600KF
Motherboard: ASUS TUF B365M - Plus
Graphics Card: MSI Geforce GTX 1660 Super Ventus XS OC 6GB
RAM: Gskillz 16GB DDR4
SSD: PLEXTOR PX 128GB
HDD: WDC 2TB
Windows 10
PSU: Corsair 750W Gold
Wireless Adaptor: TP-Link Archer T2U Nano TC600 USB
Modem: TP-Link Archer vr1600 v
 

ASK THE COMMUNITY