Question Wifi keeps disconnecting and reconnecting when playing games

Jan 31, 2022
1
0
10
0
Hello,

Every time I play online games I have a problem with unstable internet. When I play, after a couple of minutes I get disconnected and a globe icon appears in place of the wifi icon. Connection comes back usually after a couple seconds but sometimes longer. It always reconnects by itself. When this happens I lose connection only on my pc. Wifi on my iphone is working without problems.

I use a Windows desktop with an TPLink t6e wifi adapter. I tried using another usb adapter but the issue persists. The usb adapter works perfectly on another computer.

I have tried reinstalling drivers, changing power management settings, flushing dns, restarting everything many times, reinstalling windows and even switching motherboards without any improvement.

I would be grateful for any help.
 

Ralston18

Titan
Moderator
First, update your post to include full system hardware specs and OS information.

Second, verify that the wireless adapter is the only network adapter enabled on your computer. All other network adapters, wired or wireless, should be disabled.

Where on the Windows desktop is the TPLink t6e wireless adapter and the other wireless adapters being installed: front port, back port?

Feel the adapter before booting the system and then again just before playing online games.

Play as normal.

When the disconnects occur, carefully feel the wireless adapter. Is it warm or even hot?

In any case, try using a USB extension cable to raise the wireless adapter up and away from host computer.

Cooler area and likely to improve transmission and reception.
 

Dadrian Daedalus

Distinguished
May 25, 2015
109
3
18,585
0
Hello,

Every time I play online games I have a problem with unstable internet. When I play, after a couple of minutes I get disconnected and a globe icon appears in place of the wifi icon. Connection comes back usually after a couple seconds but sometimes longer. It always reconnects by itself. When this happens I lose connection only on my pc. Wifi on my iphone is working without problems.

I use a Windows desktop with an TPLink t6e wifi adapter. I tried using another usb adapter but the issue persists. The usb adapter works perfectly on another computer.

I have tried reinstalling drivers, changing power management settings, flushing dns, restarting everything many times, reinstalling windows and even switching motherboards without any improvement.

I would be grateful for any help.
i am facing a very similar issue with my system of late.Were you able to resolve the issue on your pc?If yes,please mention how.
 

ASK THE COMMUNITY