Question Wifi randomly completly dies, only way to fix is go to sleep or restart PC

FailG

Commendable
Aug 28, 2019
27
1
1,535
0
So I have this Wifi card from TPLink tl-wn781nd V3, and it randomly disconnects from the internet. Sometimes it takes hours sometimes a few minutes, I tried a lot of things like changing the pcie port, reinstalling drivers and such.When it stops working it just says "connecting" and after a while it says "Can't connect to this network". I am on Windows 11. I went to event viewer and this is what it says about the card:
Device PCI\VEN_10EC&DEV_8179&SUBSYS_819710EC&REV_01\4&342e28ef&0&00E0 had a problem starting.

Driver Name: netrtwlane01.inf
Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
Service: RTWlanE01
Lower Filters:
Upper Filters: vwifibus
Problem: 0x15
Problem Status: 0x0
 

JohnMGotts

Prominent
Dec 7, 2020
47
5
545
4
I guess the first thing I’d ask is, did it work before the upgrade and, does your equipment meet the requirements of Win11?
So I have this Wifi card from TPLink tl-wn781nd V3, and it randomly disconnects from the internet. Sometimes it takes hours sometimes a few minutes, I tried a lot of things like changing the pcie port, reinstalling drivers and such.When it stops working it just says "connecting" and after a while it says "Can't connect to this network". I am on Windows 11. I went to event viewer and this is what it says about the card:
Device PCI\VEN_10EC&DEV_8179&SUBSYS_819710EC&REV_01\4&342e28ef&0&00E0 had a problem starting.

Driver Name: netrtwlane01.inf
Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
Service: RTWlanE01
Lower Filters:
Upper Filters: vwifibus
Problem: 0x15
Problem Status: 0x0
 

FailG

Commendable
Aug 28, 2019
27
1
1,535
0
I guess the first thing I’d ask is, did it work before the upgrade and, does your equipment meet the requirements of Win11?
Well the thing is, I have built this pc recently and haven't used windows 10 at all on it. I am not exactly sure what do you mean by windows 11 requirements, does it have network requirements?
 

FailG

Commendable
Aug 28, 2019
27
1
1,535
0
Another weird thing I forgot to mention, it almost always works when connecting it to my android hotspot on my phone.
 

JohnMGotts

Prominent
Dec 7, 2020
47
5
545
4
Another weird thing I forgot to mention, it almost always works when connecting it to my android hotspot on my phone.
My rule of thumb is, always test on 2.4 because of the stronger signal strength first. Did you have any issues prior to your build?
 

FailG

Commendable
Aug 28, 2019
27
1
1,535
0
My rule of thumb is, always test on 2.4 because of the stronger signal strength first. Did you have any issues prior to your build?
Nope, It has to do something with the drivers but can't quite figure out what. Tried reinstalling drivers multiple times it just doesn't work, and yes my pc meets al the Windows 11 requirements
 

ASK THE COMMUNITY

TRENDING THREADS