Question Wifi speed drops WHEN plugged in to charge.

Jun 15, 2019
2
0
10
0
I have a 100 mbps connection and get about 92-95 mbps on 5ghz wifi near the router when the laptop is off charge. as soon as i plug it in, it goes down to 72-75 mbps every single time. and an even more frustrating issue is that many a times after some use, the wifi speed on 5ghz goes down to like 2-5 mbps regardless of whether it's charging or not. it is only fixed after 1 or 2 reboots. none of the problems i've mentioned occur on 2.4 ghz on my laptop. and neither do any of these problems occur on any of the smartphones connected to the 5/2.4 band. i don't have another pc with 5ghz wifi so i can't test that. i've checked the power options and set it to max performance. nothing changed. the wifi adapter on my laptop is an intel 8265 and my router is tp link archer c20. thank you
 
Well u already diagnose the problem, charger and/or plus charging circuit. There maybe nothing u can do if this laptop is out of warranty.

Are u using the original charger?

5G is more susceptible to EMI than 2.4

Just for kicks sometimes cables come with a cramp-on magnet, they are designed precisely to deal with EMI, got one of those, put it on the charger cable, the DC end, and pray.
 
Jun 15, 2019
2
0
10
0
Well u already diagnose the problem, charger and/or plus charging circuit. There maybe nothing u can do if this laptop is out of warranty.

Are u using the original charger?

5G is more susceptible to EMI than 2.4

Just for kicks sometimes cables come with a cramp-on magnet, they are designed precisely to deal with EMI, got one of those, put it on the charger cable, the DC end, and pray.
I'm using the original 65w Asus fast charger. The laptop is barely 4 months old so it is under warranty though. I'll try the magnet, thank you.
 

ASK THE COMMUNITY

TRENDING THREADS