Question Will an "Oculus Link" cable function as a normal USB cable for other devices? Having issues...

Wheel in the Sky

Distinguished
Aug 17, 2013
80
5
18,545
1
I bought a "Newpow Oculus Link Cable 13ft, High-Speed Data Transfer and Fast Charging, USB 3.2 Gen2 10Gbps, USB A to C" from Amazon because I wanted a USB 3.1 Gen 2 cable that was type A-to-C, and this one was a good price ($13.99) and plenty of length (13ft). I assume them calling it "USB 3.2(sic) Gen2" is a typo. Oops, USB 3.1 is magically USB 3.2 now. I can't keep up.

I don't have a VR headset though. I figure a USB cable is a USB cable, and I can use it for general purposes. It's been charging my phone fine, but today I tried to connect an external HDD to my desktop with it. It did all kinds of weird things. I thought I had a driver issue, then I thought I had a bad rear USB port on my motherboard. It's shows the HDD as unallocated space which it isn't, then it does a rapid series of disconnecting and reconnecting during which my mouse freezes, then it is no longer detected in Disk Manager, and Windows gives me varying error messages about Unknown USB Device, such as "Set Address Failed" or "Device Descriptor Request Failed." The HDD definitely works fine. This USB port is my only USB 3.1 Gen 2 Type A port, and it works when I use a different USB cable, so the USB port is not the problem. It has to be this cable.

Is it just a faulty cable, or would this probably work with an Oculus, and I'm just trying to use it for something it's not intended for? Thankfully I'm in the extended holiday return period, but I don't know if I should get a free replacement, or my money back.

This is the cable- https://smile.amazon.com/gp/product/B088RFW96T/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS