Question Will bios update from windows reset the bios?

May 15, 2019
5
0
10
Best answers
0
Hi everybody!

I recently builded a computer, and I accidentally turned off all the CSM settings, and saved... since then, I'm unable to handle the bios.
I mean, I installed a MBR partitioned windows on it, and everything works just fine,
but when I enter into the bios (UEFI), then the bios does not accept any input from my PS/2 keyboard,
neither from USB mouse, not even from USB keyboard.

What I tried so far:
It did reset some other settings which I changed (ram xmp profil), but the keyboard still not working.

To be clear, the keyboard(s) does work, and when I first entered the bios with PS/2 keyboard worked, and I'm currently using one of them on this computer to type, so...

Question(s):
If I update the bios from Win 10, then that would reset the entire bios(UEFI) and fix this issue, or it wouldn't do anything, or maybe it would make things worst?
I did read somewhere that MBR partitioned windows does not support UEFI, but if so, then when I removed the ssd, it shouldn't have worked?

My build:
Motherboard: Asrock B450m pro4
CPU: Ryzen 5 2600
GPU: Sapphire Rx 580 8GB
Ram: G.Skill aegis 8gb 3000MHz (1 yet)
SSD: Kingston A400 2.5 480GB SATA3
SPU: Seasonic 620W +80 Bronze

Other informations (from msinfo32):
bios version: 3.0 (default, not the newest)
bios mode: inherited (I'm not sure, what it means, I expected "UEFI" or "BIOS" to be shown)

Feel free to ask for any other information that can help.

I'm searching for this issue about a week or so, and I'm running out of ideas :(
I will keep trying to solve this problem, I will update this thread once it's solved.
Thanks for reading my problem! :)
 
May 15, 2019
5
0
10
Best answers
0
As it turned out, I can't update this bios from windows, it's only supports updates from a flash drive's, and in the bios...
Also I tried reseting the bios several times, by the motherboard manual, but it did not worked.
So I'm stuck again, I think I just bring it to the computer service, maybe they can fix it somehow, or buy a new one...
 

Fix_that_Glitch

Prominent
Mar 31, 2019
531
41
440
Best answers
11
Power down the system, then hold down the power button until the system beeps like 3 times. If it boots to a screen saying that the Fast-boot trigger had been detected, would I like to enable fast-boot on the next boot. Hit n for no. It should reboot again, then see if you can use the keyboard in bios.
 

geofelt

Titan
Oct 9, 2006
40,436
215
138,340
Best answers
8,108
Bios settings are saved during power off times by the cmos battery in your motherboard.
Power down(hold the power button on the case down for 5 seconds at least)
Disconnect the psu from the wall, you can remove the cmos battery for a while and the bios will be reset to default.
You may have a clear cmos button or other method to reset the bios.

Then, it is best not to use windows to update a bios.
If the process should fail for any reason, you will be left with a nasty recovery process for which you are unprepared.
Do not update a bios on speculation. Do so only if the update fixes a problem that is impacting you.
The USB method is best.
 
May 15, 2019
5
0
10
Best answers
0
geofelt, I tried that several times, and it did reset the settings, but did not solved the problem.
I used this method:

  1. Disconnect the system's power from the wall
  2. Press and hold the power button for 10 seconds to be sure residual power is discharged
  3. Place the "Clear CMOS" jumper in the clear position
  4. Remove the CMOS battery
  5. Leave the system in this state for 4 hours. 10 minutes is enough in most cases but if that yields no result then to be absolutely certain CMOS is clear I recommend 4 hours.
  6. Place the "Clear CMOS" jumper back in its original position
  7. Replace the CMOS battery
  8. Power on the system
But did not worked, I tried with 7 or 8 hour instead of 4 tho.
 
May 15, 2019
5
0
10
Best answers
0
Ok, problem solved... I guess ...
Here is what I did:

  1. Press the power button, to turn on the computer
  2. When the computer is powering up, and shows the motherboard logo, then press F11 to enter into the boot menu
  3. At the bottom left of the boot menu, there is a text says "Enter setup", select that with the keyboard or with the mouse
  4. Entered into the bios and the keyboard is working
It's weird, because if I press "Del" or "F2" to enter into the bios when the motherboard logo show's, then the keyboard still won't work in the bios.

btw, all of my bios settings was reseted, including the "CSM" settings too, so that wasn't the problem... I guess.

Anyway, thanks for the tips!

(weird problems requires weird solutions 🙂 )
 

ASK THE COMMUNITY

TRENDING THREADS