Will my new GTX 1060 work with this motherboard?

Jordy_A

Commendable
Sep 10, 2016
2
0
1,510
0
I have bought a new GTX 1060 today for my girlfriend. To my surprise, I couldn't get past the BIOS screen after I booted the PC with the new GPU in it.

I tried the new GPU in my own gaming PC and it worked just fine. Is this mobo too outdated to work with this card?

My girlfriends' mobo is a Gigabyte ATX Motherboard GA-Z77P-D3.

Full Spec List:
Western Digital Harddisk 3.5" 1TB, SATA600, WD10EARX
Corsair CX600 600W
Intel Core i3 3220 3.30GHz 3MB Box
Western Digital Harddisk 3.5" 1TB, SATA600, WD10EARX
Gigabyte ATX GA-Z77P-D3
16GB of gSkill Ram (Don't remember exactly which type.. Can't find it anywhere at this moment either, will look for names if needed)

OLD GPU: Radeon HD7770 Core Edition 1GB DVI/HDMI/DP

NEW GPU: Gigabyte GeForce GTX 1060 Windforce OC 6GB

Thanks in advance!
 

Jordy_A

Commendable
Sep 10, 2016
2
0
1,510
0


I have a Corsair CX600 600W installed in the machine.. I highly doubt that's the issue. I'm gonna update the thread with the full specs.
 

canabino

Commendable
Sep 24, 2016
3
0
1,510
0
I am having the same problem. Exactly the same system 600Watt PSU but I have a i7 processor. The latest Bios Gigabyte has is from 2012 and I have it installed. What to do?

Did you get it sorted?

Update: After removing the GTX 1060 and reverting back to my old GTX550ti it still doesn't want to start up. After pressing the power button all the fans run for a few seconds and then it shuts down and starts up by itself but nothing displays on the monitor. I have reset the bios and removed all hard drives from the Motherboard.

Any advice?
 

ASK THE COMMUNITY

TRENDING THREADS