Will this card and PSU fit in my pc?

ashesofwar76

Honorable
Jan 1, 2013
6
0
10,510
Hi so i ordered a GTX 570 for my pc and a 600w Power supply to run it now im just wondering if ill be able to fit these in my current case or if ill have to invest in a new one The computer i am using is a prebuilt HP p7-1234

the card is: http://www.newegg.com/Product/Product.aspx?Item=N82E16814130699&nm_mc=TEMC-RMA-Approvel&cm_mmc=TEMC-RMA-Approvel-_-Content-_-text-_-



and the power supply is:http://www.newegg.com/Product/Product.aspx?Item=N82E16817341017&nm_mc=TEMC-RMA-Approvel&cm_mmc=TEMC-RMA-Approvel-_-Content-_-text-_-




Also if anyone can help with the issue of my benQ xl2420t not being able to output 120hz at 1080p although i am using the DVI cable it would be greatly appreciated :wahoo:
 

ashesofwar76

Honorable
Jan 1, 2013
6
0
10,510
It's windows itself i believe. Right now im using the onboard graphics with the A6 processor. but whenever i click 120hz in Catalyst Control center it turns the resolution down to 1024x768 @ 120hz and will only run 60hz at 1080p
 

Xttony

Distinguished
Two possibilities are the inboard graphics cannot support the 120hz refresh rate or your monitor doesnot support 120Hz refresh rate and according to the model no. you specified it does support. Just double check it.
Wait for the 570 card and then try it out.
 
Just to be clear I would be very careful with buying a graphics card with the A series processors from AMD. I have a friend who bought a store bought computer that was one of AMD's A series processors. She bought a new power supply and a new graphics card like you suggested however was unable to use the card her bios would not allow her to change her adapter to pci express it was set to onboard so that I would check firstly that you can do that before considering.
 

ashesofwar76

Honorable
Jan 1, 2013
6
0
10,510


Ill keep that in mind I planned on salvaging the Ram and HD and buy a new mobo and processor next month so if it doesn't work all is well the card is supposed to be in Saturday so ill post here if I can get the 120hz working or if the card doesn't work thanks for the help so far everyone
 

Are you using a dual-link DVI cable?

Is your DVI port on your graphics card or integrated graphics DVI port on the motherboard a dual-link DVI port?

You'll need to satisfy both of the above to get 120 Hz @ 1080p working.
 
Good good :) Just remember to use the Dual link DVI cord if you don't have one you'll need to get one its the one with all the pins.

dvicon.gif