Question Win 10 prof drivers issue after using win update

RBuczynski

Reputable
Apr 4, 2016
43
0
4,560
7
Hello everyone.

I've recenty stumbled across some very irritating "feature" with my Win 10 Proff x64 1809. I've been using this system since building of my current rig (Sept 2018). Back then' I've decided to block Windows Updates, because I was afraid, that it will mess my settings. Since that time I've successfully changed GPU to better one (GTX750-> GTX 1070), put twice as more RAM, change CPU from 2400G to 3600 and do some smaller tweaks. Everything was fine and few days ago I've decided that I could give this Update stuff one more chance to show, what goodies are hidden.
However, instead of getting goodies, I've got really weird stuff.
First of all - windows decided to update not only it's own features, but drivers as well. I did not knew of that before, so when I got what's going on, it was too late. OS "updated" my graphics drivers, installed extra stuff from nv that I do not need, as well as put me some extra updates on things like AMD driver update for SMBus. Other AMD related updates are called "AMD INC System - 2.2.0.121" and "AMD INC System - 3/14/2016 12AM 2.0.1.0". None of this (in fact, none of any drivers that windows installed) are readable, once you click on hyperlink in options - all leads to empty pages, that chrome cannot load (not sure why). Only this webpage is tried to being loaded, but since there are no data there (or it has been removed), there's nothing - http://sysdev.microsoft.com/support/default.aspx .
I did not noticed that at first (I was playing), but at first my game crashed. Then - I was (and still I am) not able to properly close Windows or reboot it (Driver Power State Failure is being shown after few minutes of pc trying to shut down). What's more - both sfc and dism shown some errors from scans that I've made yesterday and today, but I'm not good enough to understand, what might be the issue there (got the logs somewhere, though). I was also somehow not allowed (no error or anything, windows just ignores my actions and seems to take them forever) to make system restore point (got it already, dism helped me there, now I'm finally able to UNISTALL something), but uninstalling or installing drivers manually still seems to be an issue. Driver manager says that waiting time was too long to finish operation, I cannot either un-install drivers or roll them back to previous version, that worked better.
I also cannot uninstall drivers updates, that Windows has brought me. I'm not able to boot into safe mode, since my pc won't close itself propertly (got an error mentioned about Driver Power Failure every single time). I'm also not able to install drivers to my gpu - either the newest one, some olders that worked before - in any case instalation stucks at the very, very begining and stays there. Even after I made a complete sweepout of old-new drivers from nv, instalator still said to me "uninstalling virtual sandbox", despite that not even being there anymore (I've deleted all files in folder, some registry data are most likely still there). Even the option "factory reset" does not work, since my pc after preparation is not able to close itself normally (seems like requested action does not give feedback to push it further and it stays on desktop and spinning wheel). After uninstalling gpu drivers I'm also not able to put pc to sleep, but my guess is that has got something to do with no drivers to put gpu to proper power state, so it is not a big deal.
Despite this issues, pc boots normally and its almost fully functional (only stuff mentioned above gives me harsh time). What else can I do to save it from formatting (it brutal, but it always works)? My true image from acronis most likely don't work, since it's image of partition, not the entire disk (sorry, but ~1TB of data, where less than 20% of it is important is too much for me to keep anywhere. I might try to recover it using bootable stick made from them, if its really necessary, but firsly I would love to see, if there's anything else that I could do from system level).

My system is original one, I've bought it in dvd box version (well, envelope wersion, ecology etc.), I did not make any overclock on this setup, besides this win update fail I did not make any programs changes recently. I also did not encouter any overheating problems (70°C is absolute maximum that this CPU got, GPU is somewhere around it with spikes to 75°C in max load) or problems that could indicate smg like broken motherboard, fried NB/SB or anything.

If someone needs info about my rig, there are basics:
Ryzen 3600 on stock + Mugen 5 rev. B
2x8 GB DDR4 3200 Gskill Ripjaws V + 2x8 GB DDR4 3200 Gskill Patriot
Asus Prime B350 Plus
Palit GTX 1070 8GB
Samsung Evo 850 SSD 1TB (system) + Spinpoint F1 750GB (storage) + ST2000 Barracuda (storage) + HGST 1TB HDD (storage)
XFX XTR 550W

Thank you kindly for all possible help.
 

RBuczynski

Reputable
Apr 4, 2016
43
0
4,560
7
Well, it might be weird, but I've found answers on my own.
Basically - re-install chipset drivers, gpu drivers (I left it on whole night, and it ended successfully), once again BAN windows 10 from auto updating drivers, and after some extra checking (smc and dism involved) it worked in my case.
Not entirely sure, how to be safe from that stuff in the future.
 

ASK THE COMMUNITY

TRENDING THREADS