Question Win 10 Ryzen 3700x System constantly crashing/restarting

Jul 13, 2019
1
0
10
0
I just upgraded my PC build to the new 3700x and now my PC won't stay booted to windows for more than a few minutes what is going on?

Build :
  • Ryzen 3700x
  • Ryzen 5700XT 50th Anniversary Edition
  • Corsair Vengance LPX 2400mhz (2x8) 16gb ram
  • MSI 370x SLI Plus
Key Notes:
  • I have updated my BIOS to the most recent MSI update for Ryzen CPU's
  • My system worked 100% fine before I installed the 3700x. I have the same spec'd build with a 1700x and had no issues, issues only arrived after the 3700x installation
  • The amount it runs in windows before crashing or rebooting is varied
  • Right before it crashes I have mouse stuttering and sound popping if music is playing, then it restarts
  • PCI Express ports are throwing errors (event 17 WHEA-Logger, PCI Express Downstream Switch port & PCI Express endpoint... both say corrected hardware error occured)
Thanks for any help, all drivers are up to date.
 
Jul 18, 2019
3
0
10
0
I have the exact same issue. Just built a new PC with MSI x570 Pro Carbon Wifi. Sabrent 1TB m.2, AMD 3900x, 2x16 Crucial 3200ram and a Evga GTX 1080 with a fresh windows install. I can't even install drivers for most things (GPU install worked), as it will do the same thing with the mouse stuttering, then blue screening with DPC_WATCHDOG_VIOLATION. I also have WHEA-Logger warnings in the event viewer and using a fresh windows install with latest windows updates.

New PC is completely unusable. I am furious....
 
Jul 18, 2019
3
0
10
0

TechyInAZ

Titan
Moderator
As @hirschbergt said, clean installs are absolutely critical when installing new CPUs.

Are you using the latest chipset drivers?

Are you using the latest BIOS?

You must be on the latest BIOS and chipset drivers to have the least amount of issues.

FYI, I just checked, the latest BIOS that supports Ryzen 3000 on that 370x SLI Plus is a BETA BIOS. So problems like this are somewhat expected.
 

valeman2012

Distinguished
Apr 10, 2012
1,178
10
19,315
21
I have the exact same issue. Just built a new PC with MSI x570 Pro Carbon Wifi. Sabrent 1TB m.2, AMD 3900x, 2x16 Crucial 3200ram and a Evga GTX 1080 with a fresh windows install. I can't even install drivers for most things (GPU install worked), as it will do the same thing with the mouse stuttering, then blue screening with DPC_WATCHDOG_VIOLATION. I also have WHEA-Logger warnings in the event viewer and using a fresh windows install with latest windows updates.

New PC is completely unusable. I am furious....
Since PCI-E 4.0 is kinda new and the PCi-e Gen4 SSD is new.. I think the OS is one have to provide WIndows Update to resolve these kinda of issues.
As @hirschbergt said, clean installs are absolutely critical when installing new CPUs.

Are you using the latest chipset drivers?

Are you using the latest BIOS?

You must be on the latest BIOS and chipset drivers to have the least amount of issues.

FYI, I just checked, the latest BIOS that supports Ryzen 3000 on that 370x SLI Plus is a BETA BIOS. So problems like this are somewhat expected.
I think its also Windows parts to provide users updates improvements for this new interface PCI-E 4?

If a full clean install did not work.
 
Jul 18, 2019
3
0
10
0
Ive figured out my issue: the WHEA-LOGGER warnings are coming from my gtx 1080. I put a 290x in and they went away. The crashing when installing drivers is coming from my Blu Ray drive connected to a sata port. I unplugged it and can now install drivers without it blue screening. Will try different sata ports later. Maybe this will help the op.
 

ASK THE COMMUNITY

TRENDING THREADS