[SOLVED] Win 10 USB install fails to load drivers

Nov 19, 2019
4
0
10
1
Hi everyone,

Long time Mac user switching back to PC here. I'm stuck installing Windows at the very beginning, before choosing any drive to install to. I've made a USB bootable installer, which loads, and takes me to a "windows needs to load drivers" message right after clicking "install".

After some research I found it may be a USB drivers issue - but the command exec. "driverquery" shows they're here.

I tried :

Different USB ports
Updating to latest BIOS
Unplugging all other Sata drives
Re-burn .ISO
Different ISO
Installing Ubuntu, & it works

I don't have access to a PC, and can't yet connect the build to the internet right now. I can download utilies over wifi from my mac only.

Has anyone experienced the same issue ? How did you solve this ? Thank you very much for your time !
 
Nov 19, 2019
4
0
10
1
Managed a workaround, for anyone running into this issue :

The problem lied in the USB bootable key, which I had made on MacOS. It kept asking for drivers, blocking Windows' install.

I made another key from the same .ISO on Ubuntu, with program "WoeUSB" (I did need to connect to the internet to get it).

This key worked normally and didn't ask for any drivers :)
 
Nov 19, 2019
4
0
10
1
Managed a workaround, for anyone running into this issue :

The problem lied in the USB bootable key, which I had made on MacOS. It kept asking for drivers, blocking Windows' install.

I made another key from the same .ISO on Ubuntu, with program "WoeUSB" (I did need to connect to the internet to get it).

This key worked normally and didn't ask for any drivers :)
 

ASK THE COMMUNITY

TRENDING THREADS