Question Win 10 Won't Let My Computer Sleep

Dynan3

Reputable
Dec 30, 2015
4
0
4,510
0
In searching for the power request in Command Mode I'm told that that program

MoUsoCoreWorker.exe

is requesting power for whatever it does, thus keeping my computer from going to sleep. This occurs since last update (KB 4565627)

Can't delete it or disable it. Don't know if I'd want to not knowing what this unknown 'guest' is doing on my computer.

I need sleep mode after ten minutes cuz I GOTS TA HAVE MY MST3K to go to sleep to...

Any ideas? Any Help?
 

Dynan3

Reputable
Dec 30, 2015
4
0
4,510
0
I got this from MS Insider Forum. Method 1 worked:

Lester BernardReyes
  • Independent Advisor
Replied on August 1, 2020
Hi

My name is Bernard and hopefully, this will help answer your question, I actually have same problem as before, nothing to worry I have steps here, and I hope that will resolved the issue.

This issue is particularly when the power options are corrupted.

Method 1. Restore default power options

- Open command prompt admin or powershell admin (Press Windows key + X then click on Windows Powershell (Admin) )

- Copy, paste and enter the command below:

powercfg -restoredefaultschemes

-Restart PC and check.

Method 2. Run power Troubleshooter

- Press Windows key + R then type:

msdt.exe /id PowerDiagnostic

- Click OK then follow the prompt to run the power troubleshooter
-Restart the device after

Method 3.

Open Control Panel> Click Hardware and Sound > Click Power Options> then click Choose what the power buttons do > Click Change settings that are currently unavailable> Check Sleep (or uncheck then check it again)

Click Save Changes then restart.


Method 4. Do clean boot

A “clean boot” starts Windows with a minimal set of drivers and startup programs, so that you can determine whether a background program is interfering with your game or program.

- In the search box on the taskbar, type msconfig and select System Configuration from the results.

- On the Services tab of System Configuration, select Hide all Microsoft services, and then select Disable all.

- On the Startup tab of System Configuration, select Open Task Manager.

- Under Startup in Task Manager, for each startup item, select the item and then select Disable.

- Close Task Manager.

- On the Startup tab of System Configuration, select OK. When you restart the computer, it's in a clean boot environment.

troubleshooting reference: https://support.microsoft.com/en-us/help/929135...

If none will work from the above solution I suggest to do an in-place upgrade wherein it will upgrade the device to the latest version and repair all issues without deleting any files.

Note: before doing this make sure to create a restore point: https://support.microsoft.com/en-hk/help/402753...

1. go to this link: https://www.microsoft.com/en-us/software-downlo...

2. Select Download tool, and select Run. You need to be an administrator to run this tool.

3. On the License terms page, if you accept the license terms, select Accept.

4. On the What do you want to do? page, select Upgrade this PC now, and then select Next.

5. After downloading and installing, it should fix the issue.

Reference: https://www.microsoft.com/en-us/software-downlo...
Note: if you receive error: “This Pc can’t be upgrade, follow the steps below”
Method 1. Go to C:\$WINDOWS.~BT\Sources\Panther then delete the file name compatscancache.dat
Then try again or reboot the PC first then try again.
You might not see the folder as it is hidden, make sure to show hidden files first.


Let me know how does it goes and I hope that helps :)

Bernard
Independent Advisor
 

ASK THE COMMUNITY

TRENDING THREADS