Win XP SP2 no TTDLX for Win works

KT1

Distinguished
Mar 25, 2005
3
0
18,510
Archived from groups: alt.games.microprose.transport-tyc (More info?)

I used to play the heck out of Transport Tycoon for DOS then Transport
Tycoon Deluxe for Windows then got Win XP and finally found TTD Patch, well
now its been atleast a year and a new harddrive, so installed Win XP, the
SP2 patch, my Transport Tycoon Deluxe for Windows and the latest patch and
guess what nothing, NADA, ZELCH, even clicked the ttdpatch file and check
Win 95 compatibility, window opens for a second and closes no running at
all. I know this worked on Win XP pre SP2, even with SP1, anyone else
having this trouble.
I have also downloaded many TTDLX for Win from the net and still no luck.
Please help I miss this game.
 
G

Guest

Guest
Archived from groups: alt.games.microprose.transport-tyc (More info?)

kt1 wrote:
> I used to play the heck out of Transport Tycoon for DOS then Transport
> Tycoon Deluxe for Windows then got Win XP and finally found TTD Patch, well
> now its been atleast a year and a new harddrive, so installed Win XP, the
> SP2 patch, my Transport Tycoon Deluxe for Windows and the latest patch and
> guess what nothing, NADA, ZELCH, even clicked the ttdpatch file and check
> Win 95 compatibility, window opens for a second and closes no running at
> all. I know this worked on Win XP pre SP2, even with SP1, anyone else
> having this trouble.

Which patch version have you tried? Maybe you can try the latest
development version if you haven't already, from
http://www.ttdpatch.net/src/

--
Josef Drexler | http://jdrexler.com/home/
---------------------------------+----------------------------------------
Please help Conserve Gravity | Email address is *valid*.
Play Chess, not Basketball. | Don't remove the "nospam" part.
 

KT1

Distinguished
Mar 25, 2005
3
0
18,510
Archived from groups: alt.games.microprose.transport-tyc (More info?)

On Fri, 25 Mar 2005 14:55:02 GMT, Josef Drexler wrote:

> kt1 wrote:
>> I used to play the heck out of Transport Tycoon for DOS then Transport
>> Tycoon Deluxe for Windows then got Win XP and finally found TTD Patch, well
>> now its been atleast a year and a new harddrive, so installed Win XP, the
>> SP2 patch, my Transport Tycoon Deluxe for Windows and the latest patch and
>> guess what nothing, NADA, ZELCH, even clicked the ttdpatch file and check
>> Win 95 compatibility, window opens for a second and closes no running at
>> all. I know this worked on Win XP pre SP2, even with SP1, anyone else
>> having this trouble.
>
> Which patch version have you tried? Maybe you can try the latest
> development version if you haven't already, from
> http://www.ttdpatch.net/src/

2.01 Alpha 47 I always check their website daily hoping something will fix
this, I also have the new graphic files too, but nothing I try works.
 
G

Guest

Guest
Archived from groups: alt.games.microprose.transport-tyc (More info?)

kt1 wrote:
> 2.01 Alpha 47 I always check their website daily hoping something will fix
> this, I also have the new graphic files too, but nothing I try works.

Hmm, ok then we'll have to figure out what the error message it is
that's shown...

So, open a command line window and enter "cd \games\ttwin95" or whatever
folder you installed it in. Then enter "ttdpatchw" and write here what
the output is.

--
Josef Drexler | http://jdrexler.com/home/
---------------------------------+----------------------------------------
Please help Conserve Gravity | Email address is *valid*.
Play Chess, not Basketball. | Don't remove the "nospam" part.
 

KT1

Distinguished
Mar 25, 2005
3
0
18,510
Archived from groups: alt.games.microprose.transport-tyc (More info?)

On Fri, 25 Mar 2005 15:25:03 GMT, Josef Drexler wrote:

> kt1 wrote:
>> 2.01 Alpha 47 I always check their website daily hoping something will fix
>> this, I also have the new graphic files too, but nothing I try works.
>
> Hmm, ok then we'll have to figure out what the error message it is
> that's shown...
>
> So, open a command line window and enter "cd \games\ttwin95" or whatever
> folder you installed it in. Then enter "ttdpatchw" and write here what
> the output is.

I have not seen this error before, but as requested:

C:\MPS\TTDHQ>ttdpatchw
Unknown language '4105' specified in the environment
variable LANG or LANGUAGE. Known languages:
English, Czech, Danish, Dutch, Finnish, French, German, Hungarian,
Italian, Nor
wegian, Polish, Russian, Spanish
Use SET LANG=language to select the language.
E.g. SET LANG=french

So I tried adding the line SET LANG=english to the ttdpatch cffg file and
still no luck.

THanx for the assistance.
 
G

Guest

Guest
Archived from groups: alt.games.microprose.transport-tyc (More info?)

kt1 schrieb:

> I have not seen this error before, but as requested:
>
> C:\MPS\TTDHQ>ttdpatchw
> Unknown language '4105' specified in the environment
> variable LANG or LANGUAGE. Known languages:
> English, Czech, Danish, Dutch, Finnish, French, German, Hungarian,
> Italian, Nor
> wegian, Polish, Russian, Spanish
> Use SET LANG=language to select the language.
> E.g. SET LANG=french
>
> So I tried adding the line SET LANG=english to the ttdpatch cffg file and
> still no luck.
>
> THanx for the assistance.

You have to set this variable in the settings for your OS.
 
G

Guest

Guest
Archived from groups: alt.games.microprose.transport-tyc (More info?)

kt1 wrote on Sun, 27 Mar 2005 06:59:24 -0500:
> I have not seen this error before, but as requested:
>
> C:\MPS\TTDHQ>ttdpatchw
> Unknown language '4105' specified in the environment
> variable LANG or LANGUAGE. Known languages:
> English, Czech, Danish, Dutch, Finnish, French, German, Hungarian,
> Italian, Nor
> wegian, Polish, Russian, Spanish
> Use SET LANG=language to select the language.
> E.g. SET LANG=french
>
> So I tried adding the line SET LANG=english to the ttdpatch cffg file and
> still no luck.

You can either make a batch file (e.g. startttd.bat) and put in the
following:

set lang=english
ttdpatchw

Then run that batch file instead of the patch. Or you can wait for alpha
48, which will automatically revert to english if the language is
unknown.

--
Josef Drexler | http://jdrexler.com/home/
---------------------------------+---------------------------------------
-
Please help Conserve Gravity | Email address is *valid*.
Play Chess, not Basketball. | Don't remove the "nospam" part.
 

sk

Distinguished
Apr 6, 2004
35
0
18,540
Archived from groups: alt.games.microprose.transport-tyc (More info?)

On Tue, 29 Mar 2005 02:22:02 GMT, Josef Drexler wrote:

> kt1 wrote on Sun, 27 Mar 2005 06:59:24 -0500:
>> I have not seen this error before, but as requested:
>>
>> C:\MPS\TTDHQ>ttdpatchw
>> Unknown language '4105' specified in the environment
>> variable LANG or LANGUAGE. Known languages:
>> English, Czech, Danish, Dutch, Finnish, French, German, Hungarian,
>> Italian, Nor
>> wegian, Polish, Russian, Spanish
>> Use SET LANG=language to select the language.
>> E.g. SET LANG=french
>>
>> So I tried adding the line SET LANG=english to the ttdpatch cffg file and
>> still no luck.
>
> You can either make a batch file (e.g. startttd.bat) and put in the
> following:
>
> set lang=english
> ttdpatchw
>
> Then run that batch file instead of the patch. Or you can wait for alpha
> 48, which will automatically revert to english if the language is
> unknown.

Well it had to happen, it was time to redo my HD anyways, so after safely
storing all important files to DVD's I reformated the HD and reinstalled
everything, then with much anticipation I installed Transport Tycoon Deluxe
for windows with the latest patch and BOOM, she ran like a charm.
So something somewhere was screwed in my old setup HD, its just bloody
weird.
But thanx for all the help, time is short now I NEED TO PLAY TTDLX :)