Win10 Cannot Update Drivers

weirdoqueen

Reputable
Nov 1, 2015
15
0
4,510
0
My PC hasn't been able to update any of its drivers for a few months now. Whenever I check my update history, it's countless alleged successful installs of the same drivers (a headset, GPU, mouse, etc), and every so often a system update that actually installs. I've got a big hunch that the problem is caused by Razer Synapse, which has been stuck on "Updating Razer Synapse" for as long as I remember this problem existing.

I've tried doing a complete reinstall of Razer Synapse, but of course that'd be too easy of a fix. I've tried Windows Update Troubleshooter and that didn't help, Malwarebytes found nothing, sfc /scannow couldn't complete, and restarting the Windows Update service also did nothing. I tried doing a reset of my system, but that stopped at 30% due to some unknown error.

I'm sure reinstalling my system would solve the problem but as always that's a hassle that I'd like to avoid.
 

Colif

Titan
Moderator
its not a hard guess when Synapse is involved, what razer hardware are you using? have you tried uninstalling synapse and reinstalling it again?

try to fix reset doing this:

right click start button
choose command prompt (admin)
type SFC /scannow and press enter
once sfc is complete, copy paste next command (bolded) into same window
DISM /Online /Cleanup-Image /RestoreHealth and press enter

SFC cleans & fixes system fioles, DISM cleans & fixes the image reset uses to reinstall win 10. If SFC had problems before you ran DISM, re run now and restart PC
 

weirdoqueen

Reputable
Nov 1, 2015
15
0
4,510
0
I did already try reinstalling Synapse as well as SFC /scannow but that couldn't complete for an unknown reason. Just for the heck of it, I'll try sfc /scannow again.

The hardware involved is the Razer Mamba 2012.

EDIT

SFC /scannow stopped at 19% with the message "Windows Resource Protection could not perform the requested operation". Checking CBS.log doesn't provide any helpful information. I'll see if I can try running it in safe mode.

EDIT 2

Running sfc /scannow in safe mode yielded the same result.
 

Colif

Titan
Moderator
did you try the dism command?

Here are some fixes you can try: https://www.infopackets.com/news/9620/how-fix-sfc-scannow-fails-wont-complete

When you get to safe mode, instead of using msconfig, use this way instead as its safer:
go to settings/update & security/recovery/Advanced start up - click restart PC now button
On the blue menu, choose troubleshoot
choose advanced
choose start up options
hit the restart button
choose a safe mode (it doesn't matter which) by using number associated with it.
PC will restart and load safe mode
 

weirdoqueen

Reputable
Nov 1, 2015
15
0
4,510
0
I entered safe mode using the method you described.

I attempted dism componentcleanup and that completed, but restorehealth stopped at 19.3% with "The file directory is corrupted and unreadable." Found this in the logs but I'm not sure what it means:

2017-03-11 20:08:50, Info DISM DISM Package Manager: PID=2176 TID=6356 Error in operation: (null) (CBS HRESULT=0x80070570) - CCbsConUIHandler::Error
2017-03-11 20:08:50, Error DISM DISM Package Manager: PID=2176 TID=11488 Failed finalizing changes. - CDISMPackageManager::Internal_Finalize(hr:0x80070570)
2017-03-11 20:08:50, Error DISM DISM Package Manager: PID=2176 TID=11488 Failed processing package changes with session option CbsSessionOptionRepairStoreCorruption - CDISMPackageManager::RestoreHealth(hr:0x80070570)
2017-03-11 20:08:50, Error DISM DISM Package Manager: PID=2176 TID=11488 Failed to restore the image health. - CPackageManagerCLIHandler::processCmdLine_CleanupImage(hr:0x80070570)
2017-03-11 20:08:50, Error DISM DISM Package Manager: PID=2176 TID=11488 Failed while processing command cleanup-image. - CPackageManagerCLIHandler::ExecuteCmdLine(hr:0x80070570)
2017-03-11 20:08:50, Info DISM DISM Package Manager: PID=2176 TID=11488 Further logs for online package and feature related operations can be found at %WINDIR%\logs\CBS\cbs.log - CPackageManagerCLIHandler::ExecuteCmdLine
I ran chkdsk /scan /forceofflinefix and that completed suffessfully.

The type of the file system is NTFS.
Volume label is Windows.

Stage 1: Examining basic file system structure ...
891904 file records processed.
File verification completed.
37606 large file records processed.
0 bad file records processed.

Stage 2: Examining file name linkage ...
1088760 index entries processed.
Index verification completed.
0 unindexed files scanned.
0 unindexed files recovered to lost and found.

Stage 3: Examining security descriptors ...
Security descriptor verification completed.
98429 data files processed.
CHKDSK is verifying Usn Journal...
38330368 USN bytes processed.
Usn Journal verification completed.

Windows has scanned the file system and found no problems.
No further action is required.

156467199 KB total disk space.
134333624 KB in 424376 files.
270744 KB in 98430 indexes.
0 KB in bad sectors.
1008431 KB in use by the system.
65536 KB occupied by the log file.
20854400 KB available on disk.

4096 bytes in each allocation unit.
39116799 total allocation units on disk.
5213600 allocation units available on disk.
Will see what else I can try, but that's where I'm at right now.
 

Colif

Titan
Moderator
do you have version 1607 of windows 10?

if you aren't sure, right click start button, choose run..., try winver and press enter

If so, try this.. the op version of DISM
Download a copy of the win 10 iso from Here - create ISO by telling it you want to make DVD - and then mount that ISO in file explorer (see Here) and then copy paste the below command into command prompt (admin)

DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:X:\Sources\Install.wim:1 /LimitAccess
Where "X" is the drive letter where the ISO is located. Simply change the "X" to the correct drive letter

if you aren't on 1607, that won't work. instead go to here and click upgrade now. this will download the upgrade assistant, run it and it will update 10 to latest version.
 
Windowsupdate can do that.

Try and install a driver and it fails. To stop it get wushowhide from the MS site. Run it click on hide. Select the drivers / whatever.

Then it'll stop trying to install them

And it'll stop failing

Because if it keeps failing until you fix it you wont be able to get windows updates either

It used to do the same thing after I had installed printer drivers. It kept trying to install/download later drivers, and failed.

And if there were any windows updates, I couldnt get them to download / because the printer driver download kept trying to download / install and failed forever.

Until I used wushowhide to hide the driver update

And I woudnt rely on windows update for everything. It wont find most of them , or it will update whatever driver, and cause probs if it installs the wrong driver





 

Similar threads


ASK THE COMMUNITY