[SOLVED] win7 converts gpt back to mbr during installation

Nov 30, 2020
3
1
15
0
Okay, I have spend countless hours on reinstalling a patched win764Proffessional version (its using the win8 installer to support skylake/kabylake cpus).

things i have tried:
shift+f10 during installation, diskpart > mbr to gpt.
linux to convert mbr to gpt
nothing seems to work, i tried it on two ssds (64 & 128gb), its gpt before installation, but as soon as windows is done installing, ssd is mbr again.

i use the asus rog maximus formula viii, the ssds have no uefi flag in the boot list, just 'p3:' and 'p4'.
the usb boot sticks with win7 installer have a uefi: though.

could someone help me, i need at least one ssd to have gpt because a program doesnt work if the sdd is mbr:/
thanks!
 
hi, uhm i think i tried this yesterday, but all ssds didnt show up anymore if i saw it right,
do i have to use rufus to create the usb stick, since it has a gpt option? i used unviersal iso to usb pendrive tool which makes the installer usb mbr, is this important?

thanks for the reply, i will give it a try now and check it again, do the ssds need to be flagged with uefi: though or will the installer make the them gpt on its own, even if the disk is mbr alredy?

edit: sorry for these weird questions, i hope i can have it fixed this week:/
I use RUFUS with the UEFI only option. Just to make sure. For UEFI bootable media. As I didn't have much luck with universal and getting the resulting USB to boot through UEFI. I keep USB of Windows 7 through 10 as UEFI only. Also one of Windows 10 for BIOS installs, just in case. 7, 8.1 and earlier I just have on DVD. Since it is extremely rare anyone wants those reinstalled anymore. It just makes life easier having separate BIOS and UEFI installers.

Those drives which don't show up. Probably aren't formatted for UEFI booting. Once you have your Windows drive installed. You should be able to switch your BIOS back to mixed. You just want it as UEFI only for installation. To be sure Windows installs in UEFI mode with GPT instead of MBR. Also disconnect any drives you are not installing the Windows to. Windows loves to install files on secondary drives without telling you during install. Files which make the computer unbootable if you ever disconnect or format the secondary drive.
 
Nov 30, 2020
3
1
15
0
Have you disabled all legacy boot options in the BIOS? If the installer boots in legacy mode. It will install the OS in legacy mode (ie MBR).
hi, uhm i think i tried this yesterday, but all ssds didnt show up anymore if i saw it right,
do i have to use rufus to create the usb stick, since it has a gpt option? i used unviersal iso to usb pendrive tool which makes the installer usb mbr, is this important?

thanks for the reply, i will give it a try now and check it again, do the ssds need to be flagged with uefi: though or will the installer make the them gpt on its own, even if the disk is mbr alredy?

edit: sorry for these weird questions, i hope i can have it fixed this week:/
 
hi, uhm i think i tried this yesterday, but all ssds didnt show up anymore if i saw it right,
do i have to use rufus to create the usb stick, since it has a gpt option? i used unviersal iso to usb pendrive tool which makes the installer usb mbr, is this important?

thanks for the reply, i will give it a try now and check it again, do the ssds need to be flagged with uefi: though or will the installer make the them gpt on its own, even if the disk is mbr alredy?

edit: sorry for these weird questions, i hope i can have it fixed this week:/
I use RUFUS with the UEFI only option. Just to make sure. For UEFI bootable media. As I didn't have much luck with universal and getting the resulting USB to boot through UEFI. I keep USB of Windows 7 through 10 as UEFI only. Also one of Windows 10 for BIOS installs, just in case. 7, 8.1 and earlier I just have on DVD. Since it is extremely rare anyone wants those reinstalled anymore. It just makes life easier having separate BIOS and UEFI installers.

Those drives which don't show up. Probably aren't formatted for UEFI booting. Once you have your Windows drive installed. You should be able to switch your BIOS back to mixed. You just want it as UEFI only for installation. To be sure Windows installs in UEFI mode with GPT instead of MBR. Also disconnect any drives you are not installing the Windows to. Windows loves to install files on secondary drives without telling you during install. Files which make the computer unbootable if you ever disconnect or format the secondary drive.
 

ASK THE COMMUNITY

TRENDING THREADS