[SOLVED] Windows 10/11 on ASUS Zenbook 14X OLED Space Edition (UX5401, 12th Gen Intel) - no drivers work after a clean install ?

Status
Not open for further replies.
Dec 3, 2022
7
0
10
0
Zenbook 14X OLED Space Edition (UX5401, 12th Gen Intel)

After clean installation W10 or W11 - the system doesn't recognize ANY drivers - so no audio, no touchpad, no graphics, no networking - nothing is working, even after downloading the drivers from official ASUS website - https://www.asus.com/us/laptops/for-home/zenbook/zenbook-14x-oled-space-edition-ux5401-12th-gen-intel/helpdesk_download/

I shipped it twice to ASUS and they repaired it twice with all that ASUS bs installed onboard that I can't stand. That's why every single time I'm trying to do a clean install of W10 or W11 - and none of those recognizes anything.

Please HELP - what might be an issue here? Why nothing is working even after the drivers were installed?
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
61,162
5,187
166,290
10,454
I bet Asus drivers won't install unless you use My Asus which is used to update all the drivers. Did you try to install it? its in the Utilities area. its possible you still missing something

I expect that is part of the Asus programs you don't like.

So you bought a laptop you hate the software for. Why did you do that?

Device only supports 11, so there aren't any win 10 drivers.

It has to be said that the difference between 10 & 11 isn't so big, its possible they work on both but Realtek have a different installer for their LAN drivers on 10 compared to 11.
https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software could try the 10 installer.
 
Zenbook 14X OLED Space Edition (UX5401, 12th Gen Intel)
After clean installation W10 or W11 - the system doesn't recognize ANY drivers - so no audio, no touchpad, no graphics, no networking - nothing is working, even after downloading the drivers from official ASUS website -
https://www.asus.com/us/laptops/for-home/zenbook/zenbook-14x-oled-space-edition-ux5401-12th-gen-intel/helpdesk_download/
what might be an issue here? Why nothing is working even after the drivers was installed?
Chipset drivers have to be installed before any other drivers. Start with that.

Make sure, you click on "Show all downloads".
By default only small portion of drivers is shown.
All drivers in chipset section are necessary. There is a lot of them. But start with Intel chipset drivers.
 
Last edited:
Dec 3, 2022
7
0
10
0
Chipset drivers have to be installed before any other drivers. Start with that.

Make sure, you click on "Show all downloads".
By default only small portion of drivers is shown.
All drivers in chipset section are necessary. There is lot of them. But start with Intel chipset drivers.
Thank you so much for that, I actually didn't even notice that. After installing all of those I have everything works perfectly fine on W10! Really really appreciate it!
 
Dec 3, 2022
7
0
10
0
I bet Asus drivers won't install unless you use My Asus which is used to update all the drivers. Did you try to install it? its in the Utilities area. its possible you still missing something

I expect that is part of the Asus programs you don't like.

So you bought a laptop you hate the software for. Why did you do that?

Device only supports 11, so there aren't any win 10 drivers.

It has to be said that the difference between 10 & 11 isn't so big, its possible they work on both but Realtek have a different installer for their LAN drivers on 10 compared to 11.
https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software could try the 10 installer.
Thank you for your answer! I have resolved an issue (the message above).

Topic is resolved.
 
Status
Not open for further replies.

ASK THE COMMUNITY