Question Windows 10 - 16GB installed but only 8GB usable

Jul 25, 2023
So i've been through some post here and other places about this problem but i haven't still been able to fix it.

I have 16GB ram but in the task managers 8GB is reserved, also says in the system 16GB installed (8GB usable).

I've tried the msconfig maximum memory thing and it doesn't work.
Have tried the virtual memory set to custom/system managed size/no paging file and none worked.
Have restored the bios to default and didn't work.
Removed the ram sticks and cleaned the dust from both the sticks and the slots still didn't work.
Tried changing slots and didn't work.
Tried placing both sticks individually on the same slot (tried slots 1/3) and they both were working (both times the computer turned on with 8 gb).
Tried using 1 stick of a different ram (1 stick of the new and 1 stick of the old) and it was still the same (16gb installed and 8gb reserved).
Factory resetted windows and still nothing.

Now the one thing i haven't seen on other posts yet is, sometimes the 16gb ram is usable but then i restart the computer and it turns to 8gb usable (yesterday I restarted the computer a lot and some times it would come up with 16gb usable and others with 8gb usable still 16gb installed).

Now i don't know if it's related to this but prior to this problem i was having some bluescreens related to System32 corrupted files but fixed it with some windows recoveries (I have already factory reset windows after this problem to try to fix the ram thing so it could not be this).

My pc specs:
Processor: AMD Ryzen 5 2600
Ram: 2x8GB DDR4-3200 Ballistix
GPU: AMD Radeon RX 6750 XT
Storage: Samsung ssd 980 pro 500gb, WDC wd 10 ezex-08wn4a0
MotherBoard: B450 Aorus Pro
Windows 10 Home 64 bit
64-bit operating system, x64-based processor
  • Like
Reactions: SharonRema
Jul 25, 2023
Thank you @rgd1101 , It worked but then i started having bluescreens and these were some of the errors i managed to caught, didn't see the errors for 2 of them:
bad system config info
kernel security check failure
system service exception what failed: win32kfull.sys

After these errors i tried updating some windows drivers but i was still getting bluescreens, so, after some research i tried updating to the latest BIOS version but it was having a problem "invalid BIOS image" so i had to update it to a previous version (previous as in below the latest).

Then, after restarting the computer i still was having the RAM issue with the xmp turned on and went to msconfig to turn the virtual memory set to custom (200 to 5000).

So everything seems to be fine for now, i've restarted the computer a few times and the 16gb RAM is being used.

@Dark Lord of Tech @SharonRema , I don't think i have/had the latest chipset drivers so i'll install them, thank you.

Thank you all for your help :)
Jul 25, 2023
So unfortunately i recently had a bluescreen error with "Windows Service Exeption" and after restarting, my pc went back to only using half my available ram, i tried to restart a couple of times and still nothing, i decided to re-install windows since im having the same bluescreen errors for more than a week now, after re-installing today i installed the drivers (chipset, windows and gpu), checked the ticked box for the maximum memory, tried to play around with the virtual memory in "View advanced system settings" and the xmp in bios and still the same issue, any tips?


What is the exact, full model number of the installed memory?

Also, did you update the motherboard BIOS with the most recent version while the memory (2x8GB) was installed?

Does the BIOS fully detect all 16GB of memory?

Try installing your memory in slots 2 and 4, per the manual instructions (page 10):


Latest posts