• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

[SOLVED] Windows 10 boot blinking cursor

Tgeer276

Reputable
Sep 3, 2015
75
0
4,640
1
So I was wondering if the slightly more advanced users on this platform could help me with an issue that I am experiencing.

I recently built my own desktop containing 2 drives. a 250 GB WD M.2 SSD and a 1TB Crucial MX500 SSD as game library. (If any other components are relevant for this issue, please mention it, I have no idea)
Now the following issue only occurs when an external drive is connected to the desktop via USB. Upon start up I am getting a blinking white cursor on a black screen for just maybe 2 seconds before the system properly boots up. I googled the issue and learned that this indicated that my System is attempting to boot from another drive. Seeing as the external Drive is the only thing different, it has to be that.
The following are my Bios Settings regarding Booting:

[Boot Option Priorities]

Boot Option #1 : Windows Boot Manager (P3: WDC WDS250G2B0B-00YS70)
Boot Option #2 : P3: WDC WDS250G2B0B-00YS70
Boot Option #3 : P0: CT1000MX500SSD1

Bootup Numlock State: On
Security Option: System
Full Screen LOGO Show

Fast Boot: Disabled

CSM Support: Enabled
LAN PXE Boot Option ROM: Disabled
Storage Boot Option Control: Legacy Only
Other PCI Device ROM Priority: UEFI Only


How do I stop this from happening?

I read once that I should change the Storage Boot Option Control to UEFI Only instead of Legacy Only but I am hesitant to try it when I am not sure what it does or whether it will work. Is that true?
 

Tgeer276

Reputable
Sep 3, 2015
75
0
4,640
1
So after contacting Gigabyte I found a solution that worked for me.
Gigabyte recommended enabling Fast Boot and disabling USB Devices during boot. I did this but initially the problem still occurred. What eventually turned out to be the problem was, that the solution above only works for USB Ports directly on the Motherboard, i.e the back of the case. Before my external HDD was connected to the Front Panel USB Ports which are connected to an internal Header on the Motherboard. For some reason the solution provided by Gigabyte doesn't affect the Cursor appearing during startup when connected to USB Ports that rout to internal Motherboard connectors.
 

Cere

Great
Jun 6, 2020
107
25
95
4
Your motherboard is seeing the device as a boot up device. You can disable “boot from usb” in your bios settings. That will stop that from ever occurring, but if you need to ever boot to a usb (ie windows repair) you’ll need to enable it before doing so.
 

Colif

Win 10 Master
Moderator
what motherboard is it?

it does look like the boot is trying to access the USB drive, I wonder what USB settings are.

I read once that I should change the Storage Boot Option Control to UEFI Only instead of Legacy Only but I am hesitant to try it when I am not sure what it does or whether it will work. Is that true?
When the storage boot control option is set to "Legacy Mode" it will be able to boot from all bootable devices that are attached to the system, regardless of whether or not they actually have bootable volumes on them. This requires the firmware to scan all devices in the boot priority for a functional MBR or GPT until one is found. The UEFI mode scans for only GPT with bootable volumes and will list in the boot priority only those that are found. Thus, in UEFI mode,it's unlikely that anyone will ever see the good old "boot device not found, please insert system disk and press enter"

https://forums.tomshardware.com/threads/what-exactly-is-a-legacy-rom-option-in-the-boot-section-of-my-bios.389681/

try changing it to UEFI
 

Tgeer276

Reputable
Sep 3, 2015
75
0
4,640
1
So changing it to UEFI Only didnt solve the problem and i also tried removing all other boot options aside from my main drive and that didnt do anything either
 

Tgeer276

Reputable
Sep 3, 2015
75
0
4,640
1
I also cannot find an option regarding boot from USB but I did find USB Configuration Options.

There settings like Legacy USB Support are listed as well as Mass Storage Devices (the external HDD connected via USB), where I can tell the computer what kind of storage it is, for instance Hard disk, floppy, auto , etc.
 

Colif

Win 10 Master
Moderator
See if this helps
right click start
choose settings
windows update
recovery
under advanced startup, click restart now
on screen after languages, choose repair this pc, not install.
choose troubleshoot
choose advanced
choose start up repair - this will scan PC and maybe fix this - will ask for logon info

just see if we can fix it from windows end.

knowing what motherboard you had might narrow down the problem.
 

Tgeer276

Reputable
Sep 3, 2015
75
0
4,640
1
So after contacting Gigabyte I found a solution that worked for me.
Gigabyte recommended enabling Fast Boot and disabling USB Devices during boot. I did this but initially the problem still occurred. What eventually turned out to be the problem was, that the solution above only works for USB Ports directly on the Motherboard, i.e the back of the case. Before my external HDD was connected to the Front Panel USB Ports which are connected to an internal Header on the Motherboard. For some reason the solution provided by Gigabyte doesn't affect the Cursor appearing during startup when connected to USB Ports that rout to internal Motherboard connectors.
 

ASK THE COMMUNITY

TRENDING THREADS