[SOLVED] Windows 10 boot issue after changing RAM setting in msconfig

VertUnix

Reputable
Jul 31, 2015
6
0
4,520
1
TL;DR Checked the max memory option in BOOT Advanced option of msconfig, now Win 10 won't boot even in safe mode. Can use a linux to modify any win configuration files.

_

As only half of my RAM was visible in my Win 10, I followed this guy's advice to check the msconfig max memory option and write the physical installed amount (after clicking on OK and reopening the BOOT Advanced Options I could see that it stayed checked but set itself to 0 ... little did I thought it can do such harm though its meaning was obvious).

The actual cause was the memory wrongfully seated in its slot so I checked the BIOS upon restarting and everything was showing well.

Now, the real issue is that Windows won't boot (Blue screen, stop code BAD SYSTEM CONFIG INFO). Things I've tried by inserting the win 10 repair tools CD:

* multiple system restores completed "successfully" but the problem persists after restart
* auto repair/ diagnosing tools
* unable to start safe mode

If it helps, I am able to boot a linux on this machine and edit any Win files that might refer to the msconfig change I did. Also, there is a basic CMD in the advanced option that can be useful.

Thank you in advance for any idea!

__

P.S. 1) Maximum Memory defaulting back to 0 is normal behavior. - source
  1. I also set no paging file, but I don't think it has anything to do with it.
  2. I didn't save a C drive clone.
 

VertUnix

Reputable
Jul 31, 2015
6
0
4,520
1
According to this article

A possible reason for the "BAD_SYSTEM_CONFIG_INFO" error is that the system configuration is incorrect. We can use the bcdedit command to set the correct values so that the number of processors and amount of memory in the configuration file match.

The cmd command solution is: bcdedit/deletevalue {default} truncatememory
 

VertUnix

Reputable
Jul 31, 2015
6
0
4,520
1
According to this article

A possible reason for the "BAD_SYSTEM_CONFIG_INFO" error is that the system configuration is incorrect. We can use the bcdedit command to set the correct values so that the number of processors and amount of memory in the configuration file match.

The cmd command solution is: bcdedit/deletevalue {default} truncatememory
 

ASK THE COMMUNITY

TRENDING THREADS