• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Windows 10 clean install get stuck at "Getting Devices Ready XX%" FOR DAYS!!

Apr 24, 2020
So, a few weeks ago my 2 year old Razer Blade decided to not boot up properly and would freeze with a spinning wheel on start-up. Nothing I did was working to fix it, so I made a windows installer on a USB (Version 1909) to try and repair it without losing any data. That kept failing, so in the end I wiped the SSD for a clean install. I booted Fromm the USB, started to install windows back onto it and it got stuck on "Getting Devices Ready XX%" (it was random the % it would get to and stop". I would leave it for up to 2 days on this before giving up and restarting the installation. That still didn't work, so I bought a new SSD, swapped it out and tried again. Same deal, it begins to install, gets stuck on "Getting Devices Ready XX%". I have tried it 3 times now with the new SSD ( my last attempt I left it on and stuck on that page for 72hrs) and NOTHING I DO WILL FIX IT!!! I desperate need help! Anyone ever had this problem and fixed it?!?
Last edited:


Win 10 Master
have you tried to run it without it being connected to internet? it could be stuck identifying a device and finding drivers.... 3 days its clearly frozen.

remove any extra USB devices as well.

on an ssd it should take 20 minutes max to install win 10. Something else inside Laptop is the cause.