Windows 10 Display goes black but pc still running with razer naga epic

RafySTi

Reputable
Nov 8, 2015
2
0
4,510
0
Windows 10 display goes black after 5-10min use, but the PC is still running, if I have sound in the background i can still listen to it so its definitely not in sleep or anything, and if I plug in a usb or click on things at random i can hear the sounds of it working; only solution is to restart PC. It's only happening with my razer naga epic 2013 mouse, which I got today (used). I figured it must be a settings issue but i can't find anything. If i use my old mouse its working fine (tired it for like an hour and no issues). Im using the naga wirelessly.

Things I've tried:
1. Setting sleep and power options related to turning off or sleeping to NEVER.
2. Going to device management and making sure the mouse wasn't allowed to turn off or put my device to sleep (it was unchecked).
3. Looked through the power settings of the Razer Synapse 2.0 software but can't find anything that relates to putting the PC to sleep. I did noticed that when i played with the slider of putting the mouse to sleep it recreated the issue.

I don't think its relevant but this is my build just in case:

ROG Maximus Hero VIII Motherboard
I7 6700k @ 4.0ghz with Hyper 212 Evo Cooler
G.Skill Ripjaws V series 16GB (2x8) 3000mhz DDR4 ram (set to 2800)
PNY GTX 970 GPU.
Windows 10 64 bit OS

The razer is conected to a regular usb 2.0
 

RafySTi

Reputable
Nov 8, 2015
2
0
4,510
0
Update:

So if this happens to anyone this seems to have solved my problems. I went into safe mode, uninstalled my old mouse's driver, used a program called display driver uninstaller and did that too, then reinatalled my display driver downloaded directly from nvidia (still in safe mode). Have had no issues 5 hours computer on no problems. Also, I changed the usb port where the razer is connected to one thats on a different control hub from my bluetooth keyboard.
 

TRENDING THREADS