Windows 10 does not see ethernet cable anymore


Oct 4, 2015

I have been using windows 10 for some time. However this morning i turned my computer on to find that my PC would no longer pick up my ethernet cable attached to it.

I have tried the following:
Replace cable.
Reatart both the PC and router.
Tried some cmd lines;

The only thing i found semi helpful in locating the problem was doing a cmd command “sfc/scannow” which returns the line “Windows Resource Protection found corrupt files but was unable to fix some of them....”

There was a command to fix it but it was unable to download because of an invalid download location.

Any tips or hints other than trying to do a reinstall?

What you can try to uninstall/reinstall the driver first.
- Go to Device Manager and uninstall the Network Adapter.
- Reboot the PC and it should reinstall the driver automatically.
- If it doesn't reinstall the driver you can use another PC and download the driver using the model number of your PC from the manufacturers website.

If all these won't work you can just run System Restore.
- Click Start then click on Settings.
- Click on Recovery and click on Open System Restore then click Next.
- Select the restore point (earlier date and time) and click Next then Finish.