Feb 14, 2023

I'm trying to install Windows 10 Pro in my new PC (first build aka I'm a newbie) and had some issues in the process. After making sure everything is properly plugged in, I did format an USB flash drive and got the latest BIOS version for my motherboard. Used the flashback port and waited until the light turned off, so I could use another USB flash drive that was previously formatted too to use it as the installation tool.

In the first boot, I got this message and pressed N so I could enter the BIOS and put the USB as 1st boot option.


Then I reset and started to install Windows, everything was working fine but at some point I got this message and I tried to solve it with the repair tool from Windows (then I saw many videos where there was another solution by using shift + f10 and changing some things but it was too late because after using the repair tool it never happened again).


After that, all I had was about 3 or 4 different error codes every time I tried to reset and it just got worse. It ended with the pc turning off by itself for some reasons I don't know many times.
After looking for some solutions, I've read things about the RAM, the graphic card or the ssd that might be wrongly connected to the MoBo or the CPU pins that could be damaged but I've checked it all and all seems to be OK.

And this is where I am right now. I updated the BIOS again with flashback so I could give it a try with nothing corrupted but I'm afraid it happens the same again so before I try to install windows, should I turn fTPM to disabled? Which of these two options if not both? Or should I do any other change in BIOS? Should I try to put a higher RAM EXPO profile?


I haven't touched anything in BIOS now nor the first time I tried to install Windows but the boot order.

AMD Ryzen 5 7600X
Kingston FURY Beast 2 x 8 DDR5-6000
Samsung 980 Pro 1 TB m.2
Sapphire PULSE Radeon RX 6600
Corsair RM750x

Thanks in advance!! and sorry if I made any mistake while writing, I'm not an English speaker.
Feb 14, 2023
When you're met with the message for fTPM, press Y, not N. See if that resolves the issue. Curious though, where did you source the installer for the OS?

MS media creator, here: https://www.microsoft.com/en-us/software-download/windows10

I solved it by disabling fTPM plus UEFI secure boot in BIOS. Also overclocked RAM to 5600mhz which is the highest frequency my mobo support page recognizes, and seems stable.

Now the only problem I have is that my Wifi antenna seems not to be catching internet. Trying to figure out how to solve it, since it is correctly plugged in the wifi 6-E ports.

Thanks for your reply!