Question Windows 10 Installed SSD Will boot in one pc but not another

Apr 4, 2019
1
0
10
0
I've just installed windows 10 on my Samsung SSD in my main pc for a friend (Asus Rog B350-f) disconnected my main boot drive and booted his up and it worked just fine. Infact I'm writing this post from it. However when I put it in his system It just goes to a black screen with a blinking line at the upper left hand corner. He's running a FX8350 and its an asrock board (I can't find a model for it) however it does have the old Blue and Grey Bios. Any help would be GREATLY appreciated. I've been working on this for a few days now. I do have access to a install media usb stick and have tried every Diskpart command I could think of, also watched every single video with this problem. I've also tried changing the settings in the BIOS and nothing worked. Thanks in advance guys.
 

Colif

Win 10 Master
Moderator
Your Ryzen system supports both UEFI and legacy MBR boot. Your friend's old AM3+ system only supports legacy MBR boot.
what he said... Your ssd is formatted as GPT. Legacy bios does not know what GPT is since it was created with UEFI and is meant to replace MBR. Legacy systems expect the boot partition to be at start of drive, that won't work with GPT as their boot info can be anywhere on the drive**

MBR = Master Boot record. Every version of Windows until Win 8 used MBR for its boot drive. MBR drives can only have 4 partitions and max drive size is 2.2TB

GPT = GUID (GUID = Global Unique ID - every single GPT drive on earth has its own number) Partition Table. GPT drives can have 256 Partitions and max drive size is 18.8 million TB

UEFI PC can boot MBR drives, but Legacy PC cannot boot GPT drives.

Even if it did work, there are always problems trying to swap an install into another PC. You could deactivate Win 10 if you did it and windows decided to check the activation servers at just the wrong time. You could just get a bunch of errors too


** UEFI PC can boot off any device so it need not be a local drive
 
Reactions: Mandark
1.
Regardless of BIOS, UEFI, GPT,etc., moving an SSD/HDD with an installed Win in it from one PC to another and expecting it to boot easily everywhere is a wrong concept. You have a wrong idea how things work.
2.
Those stuff mentioned above in the previous post.
 
Reactions: Mandark
The black screen with the flashing underscore means that the motherboard's BIOS is waiting to transfer control to a recognized bootable device. The Operating System hasn't even begun to be loaded at this point.
 

ASK THE COMMUNITY

TRENDING THREADS