Windows 10 keeps messing up my driver settings no matter what I do

lee1127

Distinguished
Jun 21, 2013
22
0
18,510
0
My problem:
Basically, since I bought Windows 10 I have had nothing but problems with drivers. It started with the USB wifi adapter, where Windows kept installing some Windows driver over the driver that came with the product. This made the wifi slower and made the wifi adapter start malfunctioning. The same happened, strangely enough, also to my graphics card after I plugged a TV screen to my PC once to play GTA V (returned to my PC screen to find the resolution all blurry and jumpy, despite being set to 1920x1080 as usual).

Now, I found that if I go to Advanced system settings>Hardware>Device installation settings, I can set "Do you want to automatically download manufacturer's apps and custom icons that are available for your devices?" to "No" (not recommended), the problem went away and I could uninstall my driver, and install again from the CD (for the wifi) and from the newest Nvidia installer (for the GTX 1060).

*However* when Windows updates it changes the Device installation setting back to "Yes (recommended)" *and* starts installing whatever drivers it likes for my devices. This is *extremely* annoying from Microsoft. Does anyone else know a solution, or has anyone had this type of problem? Maybe there is some option I am missing, or some command fix to stop Microsoft from ruining my driver settings?

Thanks in advance for the help! :)

Lee

My setup:
Motherboard: Gigabyte 990FXA-UD3 Motherboard
CPU: AMD Phenom II Black Edition X4 980 Processor, 3.70 GHz (With Noctua NH D-14 fans and heatsinks)
Graphics: Nvidia Geforce GTX 1060 6GB
Memory: 8 GB of RAM (4x2 GB Modules - Corsair XMS3 DDR3 TW3X4G1333C9A 1333 MHz)
OS: Windows 10 Professional on a Samsung 860 Evo 500 GB SSD (Also contains all program files)
Mass Storage: 1 TB Harddrive (Hitachi HDS721010CLA332 SCSI Disk Device), from my previous setup
Power supply: Corsair Enthusiast TX750 V2 Power Supply (750W)
Disc reader: LG GH24NS90.AUAA50B 24x SATA Bare Internal DVD Rewriter[strike][/strike]
 
If you’re using Windows 10 Professional, Enterprise, or Education, the easiest way to change this setting is by using the Local Group Policy Editor.

To open the Group Policy Editor, press Windows+R, type “gpedit.msc” into the Run dialog box that appears, and then press “Enter.”

Navigate to the following path in the left pane of the Local Group Policy Editor window:

Computer Configuration/Administrative Templates/Windows Components/Windows Update

Double-click the “Do not include drivers with Windows Updates” option in the right pane.

Set the option to “Enabled” and click “OK.” You may need to restart your PC before this setting takes effect.
 
If you’re using Windows 10 Professional, Enterprise, or Education, the easiest way to change this setting is by using the Local Group Policy Editor.

To open the Group Policy Editor, press Windows+R, type “gpedit.msc” into the Run dialog box that appears, and then press “Enter.”

Navigate to the following path in the left pane of the Local Group Policy Editor window:

Computer Configuration/Administrative Templates/Windows Components/Windows Update

Double-click the “Do not include drivers with Windows Updates” option in the right pane.

Set the option to “Enabled” and click “OK.” You may need to restart your PC before this setting takes effect.
 

lee1127

Distinguished
Jun 21, 2013
22
0
18,510
0


Thanks for the advice! I have enabled this option and will see if it takes effect properly, by installing the next Windows Update when I see it.
 

ASK THE COMMUNITY

TRENDING THREADS