Question Windows 10 Mail app displays text as question marks in box

Yanitwei

Reputable
Dec 7, 2016
37
0
4,540
3
Hi all,

I have an issue with windows 10 Mail app.

Every text that is written in Armenian language being shown as boxes or question marks inside the box, But only inside Mail app and only inside that message.
If I will copy it and paste somewhere else, doesn't matter where, normal text immediately will appear, However only inside the message it displays as unknown boxes.




I'm using regular Armenian Phonetic downloaded from Windows 10 language preferences.
I tried configuring language for non-unicode programs to Armenian, changed regional settings to Armenian but there still appear as boxes.


I'm using Windows 10 1903
Mail app is up to date!
 

Yanitwei

Reputable
Dec 7, 2016
37
0
4,540
3
Does this happen with every email, or just from a specific sender(s)?
No sir it happens with most of senders, even from "if others equal PC" e.g. same windows same installed progs and fonts, same app and same Outlook ecosystem email.
And same thing is happening on that PC as well.

However, in browse Outlook or office 365 version the mails and text in Armenian are displaying correctly. I cannot determine when exactly, after what change it started to show boxes instead of letters, but it wasn't always like this
 

Yanitwei

Reputable
Dec 7, 2016
37
0
4,540
3
Go to "Control Panel", "Regional" (or "Settings", "Language", "Administrative Language Settinfs), click on "Administrative", then "CHange System Locale". Change it to Armenian, reboot, and see what happens.
Tried already nothing changes :(

Today I also tried to email to myself from that computer, and text was OK, however in some of my previous replies text now is being shown as boxes...

So I made some experiment. I copied that "unknown boxes", created a new message and pasted there. They were still in same square shape, then I tried to convert that boxes from ansii to unicode and past back next to unknown boxes and the text was normal.

Does it means that some fonts aren't supporting unicode ? but if I only stick into unicode, Then from where on the earth ANSII could appear around there ??

I think Mail app in some places automatically changing Fonts either it is some kind of bug or because some Font is not supporting Unicode and it's changing writing to ANSII...


What you think guys ?
 
I'm also heavy user of non-Latin alphabet in Mail, and for last ten or so years haven't had any troubles with properly written emails. It might turn that your senders are sending them as non-Unicode (using Armenian code page), or without code-page information embedded into the message, and you must have same installed on your computer to display them properly.
 

ASK THE COMMUNITY