Question Windows 10 Mouse Latency

Dec 26, 2020
8
0
10
0
So ive been having alot of trouble with mouse latenc/input delay. It started a couple of years ago, and i got kinda used to it. But lately its been 24/7. Before it was only in some certant games, now its constant. And the cursor in general is delayed. Its not alot but a amount thats super annoying, since im a competitive fps shooter. So minimal delay is the target, ive watched so many tutorials on how to fix it but i cant really seem to find a the right solution. Some things i tried:
The mouse cursor options, 6/11. And disabling all acceleration. Disabling g-sync which i heard can cause some input lag. I tried changing some setting sin bios that were supposed to help. But nothing happend
Reinstalling windows
Mutliple programs that are supposed to help.
Some changes in regedit.

Ive also changed some of my hardware, such as cpu, and motherboard.
I got a 1060, which im gonna upgrade.
Gigabyte z390m
Ram 16Gb 3200Mhz
Intel i7 9700k
aoc g2460pg
Logitech g pro wireless.
Thats all the hardware i think is useful to fix this problem.

Hope its someone here that might know how to fix this problem.
 

MPF-Dean

Reputable
Jan 2, 2017
206
5
4,865
51
Okay nice,

Second step go to the mouse manufacturer and download their latest driver
Third Turn off cortana
Fourth check your power settings for USB ports (the dongle the wireless mouse connects to, could be getting less than required power)
Fifth, how far away from the dongle are you? Any difference at all when close to it - like 2 cm away?
 
Dec 26, 2020
8
0
10
0
  1. im using there software, so the updates automaticly, and i also manually downloaded it.
  2. Already done it
  3. My motherboard is all supported to have stuff like that. Even the 3.1 usb port, which is meant for gaming. Still no difference.
  4. Doesnt matter the distance of the dongle from the mouse, im using a usb wire from the pc which connects the usb reciever at the end. No difference
 

MPF-Dean

Reputable
Jan 2, 2017
206
5
4,865
51
5. In Devices settings, click "Mouse" (or "Mouse & touchpad") on the left pane and then try disabling and enabling the "Scroll inactive windows when I hover them" feature a few times and check if the issue is resolved.

6. Power settings > System options > Click on "Change settings that are currently unavailable" and then uncheck the "Turn on fast startup (recommended)" option if it is enabled. Click "Save changes" to save the changes made.

7. In the USB Hub device properties window, click the "Power Management" tab and uncheck the "Allow the computer to turn off this device to save power" checkbox. Repeat these steps for all USB Hub devices your computer.

8. Can you please check your event log and make sure there are no hardware warnings/errors relating to the mouse
 

MPF-Dean

Reputable
Jan 2, 2017
206
5
4,865
51
Damn man, after that - I wouldn't have much options besides remoting in and checking - which this place bans and I wouldn't for liability/your protection.

Your other option would be to;

9. Test this same mouse on another PC - that will tell you if its the mouse or the PC, if its the mouse - might need to go under warranty repair if can
If PC - Reinstall windows - safe your time
 

ASK THE COMMUNITY

TRENDING THREADS