Windows 10 often not turning display off after specified time

aafusc2988

Reputable
Jan 8, 2015
328
0
4,810
5
The only difference between this newly built PC and my old Windows 7 PC in terms of programs are now I have Norton Antivirus. I usually always leave Battle.net and Steam open, as well as AFK in my friend's Mumble server. I believe the culprit to be Norton Live Update as when I manually run a Live Update the display will sleep. But if a new update(s) have come that have not automatically downloaded (I.E, I could run it and it would update), then this seems to hang the display from ever turning off after my 15 min specified time. I have the PC to NEVER sleep.

Any insight?
 

aafusc2988

Reputable
Jan 8, 2015
328
0
4,810
5
I did go to Device Manager and was able to get a driver for my monitor. It changed from 'Generic PnP Monitor' (or something like that) to some string of letters/numbers which I guess identified my monitor as my ACER. Could this have been the culprit? After getting the driver I went to bed, but noticed all night the display was on... was too tired/lazy to get up and mess with it. My display stayed on all night despite being set to turn off after 15 minutes. This morning I restarted the PC and after 15 mins of idle time it went to sleep right away...

Was it just because I didn't restart after getting the driver? Right now it just seems completely random on whether or not it sleeps or not. I deleted ASRock RGB program thinking it was that.. I turned Logitech Gaming Software off from startup (yet it started in the task bar after startup and was back to 'On' in Startup Apps - WTF?) Weird quirks with Windows 10... why did Logitech turn itself back on as a startup app after I turned it off a few days ago? This was my first restart since doing that and it just puts itself back as a startup app..

Also upon entering the Logitech Gaming Software, it prompted me to allow access again, but the Private Network such as my home, etc was greyed out with a check mark. The only option to change was a Public network and I unchecked that. Why was the Private Network option greyed out? How can I fix that?
 

aafusc2988

Reputable
Jan 8, 2015
328
0
4,810
5
Is the greyed out private network because my Network (Ethernet) is set to Private - thus I have to have that one checked by default. This must be a new feature of Windows 10 because both boxes were always able to be checked before in Windows 7 to choose Private or Public Network for what program you were allowing your PC to access.
 

mortemas

Reputable
Feb 11, 2015
505
19
5,165
60
My screen saver didn't properly kick in for months. Windows pushed the October update to my PC a few weeks ago and that's what fixed it for me. Did you try selective startup or end nonessential tasks to find out what is causing the monitor to stay awake? You might have to turn off startup of Logitech Gaming Software by going into the in-app settings, not the Windows Startup settings.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts