Question Windows 10 partition MFT got corrupted and appear as RAW

ghsch

Prominent
Feb 10, 2021
2
0
510
0
Recently, I've installed a Linux distro in the SSD, which cointains Windows 10 in another partition. I did shrink the Windows' partition through the Linux install wizard, which kinda broke Windows 10 boot process (didn't shrink used space, only free).

After some problems with the Linux install, I've edited the EFI folder contained in the FAT32 EFI partition using the Linux distro's live USB. This removed Windows 10 boot entry, and I've managed to restore the contents of the EFI folder to the original order, but I think it maybe messed the permissions of the files, because the boot entry didn't appear after I've tried to fix it.

I've tried fixing the filesystem with chkdsk and also tried re-generating the EFI folder though Windows installation media. None worked.

One thing that worked was the TestDisk utility, which gave me the ability to access the files contained in the partition after repairing the MFT and Boot sector. I've done it in the Linux live environment, and after that, could mount the partition and read it.

This is a work PC, so I want to avoid having to reinstall Windows from scratch, even if I'm able to recover the files through Linux live USB.

Is there something I can do to rebuild the NTFS filesystem and recreate the EFI partition with Windows' boot files?
 
Last edited:

ASK THE COMMUNITY