Question Windows 10 RE (& Macrium PE) driver issues on Asus X205TA ?

gutai

Honorable
May 10, 2014
6
0
10,510
0
On Asus X205TA, there is issue with Touchpad on Windows 10, that wasn’t the case with Windows 8 as it had come pre- loaded with. Later Asus release Smart Gesture driver that fixed the problem in booted Windows, but not for Win RE or PE environment – neither keyboard nor touchpad worked in RE or PE environment. This is an UEFI system with GPT disk. Whereas, my other system laptop Lenovo G570 (Legacy BIOS, MBR) had no issues in Win RE/PE environment whatsoever with any drivers.

The problem is particularly ominous while using Macrium PE for restoring images on Asus X205TA as neither Keyboard nor touchpad works. I am not sure if Asus is the problem or Windows 10 or Macrium Reflect; but any insight on this would be greatly appreciated. Asus X205TA has latest BIOS (Ver. 213), and all latest drivers installed.

Interestingly, if advanced options is entered through Shift+Restart, the RE picks up both keyboard and touchpad support from OS; BUT on a fresh start directly to advanced options it never gets the keyboard or touchpad support and results in no input device in RE. This is essential because if Windows become unbootable, then Macrium Image Restoration is the only way out to fix this problem quickly, and that is the whole point of using Macrium Reflect actually. I have tried picking up drivers individually during Macrium Reflect boot menu creation but to no avail. Even manually extracted inf dll & sys files to C:\boot\Macrium\WinRE Drivers – which didn’t help either.

Both systems run on Windows 10 19H2 (build 18363.997). Native Win RE version was used in both cases.

Thanks for any solution/leads.
 
Last edited:

ASK THE COMMUNITY