Question Windows 11 Desktop PC taking several minutes to boot, plus it won’t wake up from sleep ?

Jan 23, 2023
Apparently, unrelated to anything I describe below, one of my SSDs died, and that was causing the boot issues.

Recently, my home-built PC has started to have two issues: first, whenever it boots, there is now a several minute long period between the initial BIOS prompt (a little underscore on the screen) and the Windows spinny boot screen where the monitor is blank (lit, but black). The Windows bit and the BIOS prompt bit seem standard, but this segment between them is absurdly long. This is strange because I have a monster PC (specs below) and this has never been a problem before.

Second, whenever I put my computer to sleep for an extended period (i.e. over an hour) it won’t wake up. Some USB peripherals still seem to get power, but nothing else happens.

  • Motherboard: MSI Z690 Tomahawk WI-FI DDR4
  • CPU: Intel i9-12900K
  • RAM: 64GB GSkill Ripjaws V DDR4 3600
  • Windows 11
Unfortunately, there are several potential triggers for the change, though there’s no guarantee any of them are actually the culprit:
  1. I recently got a TV I wanted to occasionally use as a 4th monitor. My 3rd monitor is a drawing tablet that I don’t always use, so it’s off. Plugging in the TV seemed to cause a weird issue where the tablet wouldn’t recognize the output. I tried restarting and that’s when I noticed the boot issues.
  2. I also recently added a new NVME storage drive (prior to getting the TV, though I don’t remember the booting process becoming longer after installing it). Regardless, removing it didn’t fix anything.
  3. In an attempt to fix the boot issues, I tried resetting the CMOS by unplugging the machine and removing the motherboard battery for 30 seconds. Obviously, it didn’t help, but I hope it didn’t make things worse.
  4. I have XMP on. It’s never caused any issue before, but I’m not sure if prolonged use makes a difference.
  5. During boot I’ve noticed that the motherboard’s VGA LED is on for a while when it’s booting, which, according to the manual, means it’s trying to find a graphics output. This suggests that maybe the GPU is the culprit, but removing it and running a DP cable directly into the motherboard doesn’t help (the VGA light still remains on for a while).
Other things I have tried to no avail:
  1. Clean installing new graphics drivers.
  2. Clear out the boot order leaving only the boot drive enabled.
  3. Flash the BIOS.
Any help in narrowing down culprits would be appreciated.
Last edited: