Question Windows 11 health check on Windows 10 Pro ?

Oct 16, 2021
1
0
10
0
Hello,

whenever i run the windows 11 pc health check app on windows 10 pro, i always get "this pc must support secure boot". you can then click on "more about enabling secure boot" for further instructions but these instruction don't work, in my case.

I can not successfully configure the Secure Boot function of my ASUS Z390-A PC with the Windows 11 PC Health Check App. in the "article windows-11-and secure-boot" the instructions on microsoft's website outlines that one go to the "settings/update & security/recovery and restart" choice. upon rebooting and selecting "troubleshoot/advanced/uefi firmware settings" the last portion is not an available choice. as a result, i think the lack of this option might be the root cause.

my current os is windows 10 pro version is 21h1 and the os build 19043.1288. i have all of the current updates for windows 10 pro, the latest BIOS for ASUS (1902) but i need some guidance.

Anyone have a suggestion or 2 ?

many thanks,

pablo.2
 

zesun

Honorable
Jul 11, 2015
151
2
10,715
19
I guess it's TPM you need to enable. Restart your pc and keep pressing the DEL key to get into your bios. Enable advanced view (F7) and look for TPM and enable. I think it's actually called PTT on intel platforms. Look for it under advanced in your bios settings. - Exit and save and then you should be good to go.

Edit: What is your cpu btw?
 
whenever i run the windows 11 pc health check app on windows 10 pro, i always get "this pc must support secure boot". you can then click on "more about enabling secure boot" for further instructions but these instruction don't work, in my case.
Please show screenshot from Disk Management.
Switching to UEFI boot from legacy boot requires drive partitioning change from MBR to GPT.
 

ASK THE COMMUNITY