[SOLVED] Windows 22H2 causing laptop to go to sleep randomly

ethan206

Reputable
Jul 27, 2018
156
1
4,695
1
I recently updated to Windows 11 22H2 and ever since I've been having sleep problems with my laptop. It doesn't matter if I'm gaming, browsing the web, or simply just idling; Windows will randomly go to sleep and I'll have to press the power button to turn my laptop back on. And then one time when I tried turning it back on I got a BSOD saying it was a 'WHEA UNCORRECTABLE ERROR' which supposedly is a hardware-related issue that I highly doubt as this only started happening when 22H2 got installed. I've updated all my drivers (most importantly the NVIDIA & AMD display drivers) and the issue still persists. I've triple-checked both Settings & Control Panel to make sure my sleep settings are set to "Never" and I feel like I'm out of options at this point. I still have three days left before Windows won't allow me to roll back 22H2, but I'm using that as a last resort cause I'm not sure how backing up all my files & restoring everything will work.

Laptop: Razer Blade 2021 (RTX 3060, 5900HX)
Windows 22H2
 

Darkbreeze

Retired Mod
Yeah, so, honestly, I'd just avoid all the BS and just do a clean install. Certainly there are usually ways to resolve most problems if you want to spend that much time in figuring it out, and for some people that might mean months of troubleshooting, but downloading the Windows media creation tool, creating fresh 22H2 installation media and doing a clean install and then reinstalling your programs is likely to take a lot less time and be a lot less frustrating.



But, before you do that you might also want to simply try disabling both fast startup and hybrid sleep.

If you have a laptop as I mentioned above you do not want to disable Hibernation. You can instead disable two aspects of it which may be causing you problems. These two aspects are Fast Startup and Hybrid Sleep. Fast Startup combines Hibernate and shutdown, while Hybrid Sleep combines Sleep and Hibernation. Both of those can cause problems with shutting down or Sleeping.

To disable Fast Startup: (does not apply if you have disabled Hibernation)

Open up Power Options in the Control Panel. In Windows 10 you can get there from right clicking on the start menu and going to Power Options
Once there, on the left hand side, click "Choose what the power buttons do"
Click "change settings that are currently unavailable" up at the top
Down below under the "Shutdown Settings" section you will see "Fast Startup" check-boxed. Uncheck the box
Click OK

Disable fast startup screen

To disable Hybrid Sleep: (does not apply if you have disabled Sleep or Hibernation)

Open up Power Options in the Control Panel. In Windows 10 you can get there from right clicking on the start menu and going to Power Options
Click "change plan settings" next to your current power plan
Click "change advanced power settings"
Click the + sign next to "Sleep"
Click the + sign next to "Allow hybrid sleep" and change setting to "off"
Click OK
 

Darkbreeze

Retired Mod
You DO have everything important, that would cause you to have a mental health breakdown, backed up elsewhere such as external media/drive, cloud storage, etc., already, right? I'm talking personal folders, files, documents, music, movies, settings, bookmarks, etc.?
 

ethan206

Reputable
Jul 27, 2018
156
1
4,695
1
You DO have everything important, that would cause you to have a mental health breakdown, backed up elsewhere such as external media/drive, cloud storage, etc., already, right? I'm talking personal folders, files, documents, music, movies, settings, bookmarks, etc.?
Well, I did use File History for a bit and then it got bricked (ironically by a Windows update) and I never found out how to fix it, so my files haven't been backed up since June. You're thinking I should rollback 22H2 and then restore my backup files?
 

Darkbreeze

Retired Mod
No. I'm thinking you should consider backing up any important PERSONAL files, not "Windows files", specifically, what I outlined, and to anyplace other than the drive Windows is on (Which you SHOULD always have regularly anyhow. Backing up things to the same drive where the problem might exist is NOT a solution or a remedy, as, if the drive fails, and it WILL, sooner or later, you'll lose both with no way to regain it. Real life isn't the movies. You don't just get to load some software and recover all your lost files from a dead drive) and then do a CLEAN install of Windows.

Because it sounds to me like there is more going on that you've said, and that it's likely this installation has been around a while. When was the last time a clean install was done? Ever?

Did that laptop come with Windows 11 on it or Windows 10 and have you ever done a clean install since purchasing it or are you still riding the same bloated installation it came with?
 

ethan206

Reputable
Jul 27, 2018
156
1
4,695
1
No. I'm thinking you should consider backing up any important PERSONAL files, not "Windows files", specifically, what I outlined, and to anyplace other than the drive Windows is on (Which you SHOULD always have regularly anyhow. Backing up things to the same drive where the problem might exist is NOT a solution or a remedy, as, if the drive fails, and it WILL, sooner or later, you'll lose both with no way to regain it. Real life isn't the movies. You don't just get to load some software and recover all your lost files from a dead drive) and then do a CLEAN install of Windows.

Because it sounds to me like there is more going on that you've said, and that it's likely this installation has been around a while. When was the last time a clean install was done? Ever?

Did that laptop come with Windows 11 on it or Windows 10 and have you ever done a clean install since purchasing it or are you still riding the same bloated installation it came with?
The laptop came with Windows 10 and I've been using it for a year. And Windows 22H2 actually released a week ago so it's pretty recent. I did not do a clean install but I did clear out most of the bloatware that came pre-installed. And the problem is that my internal drive is 2TB and File History would only work with 2TB+ drives and I currently don't have access to a 2TB+ external drive.
 

Darkbreeze

Retired Mod
Yeah, so, honestly, I'd just avoid all the BS and just do a clean install. Certainly there are usually ways to resolve most problems if you want to spend that much time in figuring it out, and for some people that might mean months of troubleshooting, but downloading the Windows media creation tool, creating fresh 22H2 installation media and doing a clean install and then reinstalling your programs is likely to take a lot less time and be a lot less frustrating.



But, before you do that you might also want to simply try disabling both fast startup and hybrid sleep.

If you have a laptop as I mentioned above you do not want to disable Hibernation. You can instead disable two aspects of it which may be causing you problems. These two aspects are Fast Startup and Hybrid Sleep. Fast Startup combines Hibernate and shutdown, while Hybrid Sleep combines Sleep and Hibernation. Both of those can cause problems with shutting down or Sleeping.

To disable Fast Startup: (does not apply if you have disabled Hibernation)

Open up Power Options in the Control Panel. In Windows 10 you can get there from right clicking on the start menu and going to Power Options
Once there, on the left hand side, click "Choose what the power buttons do"
Click "change settings that are currently unavailable" up at the top
Down below under the "Shutdown Settings" section you will see "Fast Startup" check-boxed. Uncheck the box
Click OK

Disable fast startup screen

To disable Hybrid Sleep: (does not apply if you have disabled Sleep or Hibernation)

Open up Power Options in the Control Panel. In Windows 10 you can get there from right clicking on the start menu and going to Power Options
Click "change plan settings" next to your current power plan
Click "change advanced power settings"
Click the + sign next to "Sleep"
Click the + sign next to "Allow hybrid sleep" and change setting to "off"
Click OK
 

ethan206

Reputable
Jul 27, 2018
156
1
4,695
1
Yeah, so, honestly, I'd just avoid all the BS and just do a clean install. Certainly there are usually ways to resolve most problems if you want to spend that much time in figuring it out, and for some people that might mean months of troubleshooting, but downloading the Windows media creation tool, creating fresh 22H2 installation media and doing a clean install and then reinstalling your programs is likely to take a lot less time and be a lot less frustrating.



But, before you do that you might also want to simply try disabling both fast startup and hybrid sleep.

If you have a laptop as I mentioned above you do not want to disable Hibernation. You can instead disable two aspects of it which may be causing you problems. These two aspects are Fast Startup and Hybrid Sleep. Fast Startup combines Hibernate and shutdown, while Hybrid Sleep combines Sleep and Hibernation. Both of those can cause problems with shutting down or Sleeping.

To disable Fast Startup: (does not apply if you have disabled Hibernation)

Open up Power Options in the Control Panel. In Windows 10 you can get there from right clicking on the start menu and going to Power Options
Once there, on the left hand side, click "Choose what the power buttons do"
Click "change settings that are currently unavailable" up at the top
Down below under the "Shutdown Settings" section you will see "Fast Startup" check-boxed. Uncheck the box
Click OK

Disable fast startup screen

To disable Hybrid Sleep: (does not apply if you have disabled Sleep or Hibernation)

Open up Power Options in the Control Panel. In Windows 10 you can get there from right clicking on the start menu and going to Power Options
Click "change plan settings" next to your current power plan
Click "change advanced power settings"
Click the + sign next to "Sleep"
Click the + sign next to "Allow hybrid sleep" and change setting to "off"
Click OK
Ok this sounds really dumb but another thought just occurred to me and I'm not exactly sure if this is the reason or not. I recently just bought an Apple Watch (like I think I got it the day 22H2 got installed) and I read about how some laptops use magnets to determine when the lid gets shut and when to put the laptop to sleep. Is it possible that my Apple Watch is somehow triggering the magnets (because I usually leave it on my wrist when I'm using my laptop) and tricking my computer to go to sleep?

Also, I couldn't find Hybrid Sleep in my advanced power settings and I think I already have Hibernation on? I usually put my computer to sleep a lot, but should I start setting it to hibernate?

Also 22H2 had a new patch/update today and so far I haven't experienced a sleep crash (yet). Although I also tested the theory with the Apple Watch and I haven't been wearing it so maybe that too?
 

Darkbreeze

Retired Mod
Apple watch, no.

Hibernate, no. In truth I'd disable hibernation and only use sleep. Especially if you don't leave the laptop on, close it and then leave it unplugged for long periods of time because it could shut down and cause you to lose work once the battery gets low enough. If you don't ever do that, then completely disabling hibernation would be preferable to disabling hybrid sleep or fast restart, because it would automatically do both those things.

But if it hasn't had problems since the patch, then it's a moot point.
 

ASK THE COMMUNITY

TRENDING THREADS