Windows 7 and Samba Issue

Status
Not open for further replies.

LVDAX

Distinguished
Jan 20, 2007
2,156
0
19,780
0
Not expecting much from this but i figured i'd throw it out there to see if anyone else has seen it.

I have a Windows 7 machine on my test network here whenever i attempt to connect to a linux based file server on the network it kills samba on the server. The steps go like this:
Start
-search programs....
\\server.domain.com or \\xxx.xxx.xxx.xxx (IP address fo server)
-Windows 7 can't find server error (even if i run the repair)
Immediately afterwards the samba service on the file server crashes and is non-responsive to other computers on the test network.
My Vista machines don't have this issue.

Anyone else seen this? If not then keep your eyes open if you run into a similar issue.

Besides this i like the new OS.
 

nikonz

Distinguished
Feb 13, 2009
1
0
18,520
1
Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options
 

ergosteur

Distinguished
Jan 15, 2009
1
0
18,510
0
I also have this problem with the SMB servers on my Linux box, Mac and cheap NAS. This is really make or break for me, if there's no fix, I'm going to be sticking with XP, because it has no problems accessing devices running other OSes.
 

sirloxelroy

Distinguished
Jan 20, 2009
1
0
18,510
0
I actually have Windows 7 working with my Mac OS X 10.4 Server, and my SuSE Samba Server. I used the Vista Hacks on this page to get it to authenticate: http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p=339270746 And then added
ntlm auth = YES, lanman auth = YES (which without the hack kills the Win 7 Machine from looking), client ntlmv2 auth = yes to my smb.conf. Still trying to get it to join a samba domain.
 

CompTechPC

Distinguished
Jan 23, 2009
3
0
18,510
0
Samba ok here? Windows 7 beta 32 bit and Ubuntu Linux 8.04 32 bit. Perhaps it's an issue with a particular distro? I can access from XP and Windows 7, the Samba service doesn't crash. I remember hearing something on the Floss weekly podcast episode 14 about Microsoft changing something within its networking protocols to deliberately thwart interoperability with Samba. Listen 35:00 minutes in. “The Microsoft engineers were apparently told to F*$k with Samba”!
 

CompTechPC

Distinguished
Jan 23, 2009
3
0
18,510
0
Well a week later and I'm trying to connect to my Samba share and guess what no dice! Seems I counted my chickens before they hatched! No connectivity from the Windows 7 computer, although the XP virtual machine which is a guess OS inside 7 connects great! Thanks Microsoft!
 

CompTechPC

Distinguished
Jan 23, 2009
3
0
18,510
0
Hooray! I am able to once again connect to my Samba share via Windows 7 after removing the stored credentials for the Samba share. Control Panel -> Credential manager.
 

rzercher

Distinguished
Feb 24, 2009
1
0
18,510
0
Yep. Same problem here. I read somewhere in the release notes for windows 7 that it does not support workgroups. The homegroup thing is a little unintuitive. I read that you must have a 2008 server running to create a domain that supports active directory for windows 7.

I guess microsoft is back to their unsociable proprietary quest for total control again. I was hoping that it would be a little more interoperable...

I downloaded the Server 2008 from the technet but it comes down as an .exe. (not .iso) So the only way I figure you can install it is over the top of a windows build. (probably vista or XP) I'm betting that they will have the same problem getting companies to go to server 2008 that they are having with the deployment of vista.

7 seems to run faster than vista but this failure to embrace diversity seems to be a little racially biased for me. Same old Bill Gates.
 

thousandrobots

Distinguished
May 4, 2009
1
0
18,510
0


Thanks, nikonz. This worked for me. Windows 7 Beta (client) and Mac OS X 10.5.6 (server).

My trouble wasn't that the server was turning off...it was that the client wouldn't connect at all.
 

Zoron

Splendid
Bill Gates has little to do with MS these days. This is a beta, you cannot possibly expect that something like Samba interopability would be up and running 100%... that's why you have the feedback option. Samba is probably not a high priority at this point, but to suggest they would intentionally break it is Chicken Little-ish. It might even be fixed as of the Release Candidate which is available today.

Anything less would be a PR disaster for MS. They cannot appear to intentionally break anything at this point, because the anti-trust people would be all over them.
 

markey164

Distinguished
May 6, 2009
2
0
18,510
0
Interestingly i didn't have this issue with Windows 7 Beta (LAN manager authentication level was already set to send NTLMv2 responses only, security was set to 128bit) and I had no problems accessing my Samba shares.

However in Windows 7 RC, the LAN manager authentication level wasn't defined, and i could not access Samba shares. As soon as i set it as per nikonz post, it worked again.

Many thanks for the fix :eek:)
 
G

Guest

Guest


Be sure the SAMBA shares on the server are mounted as CIFS volumes.
 

macgruff

Distinguished
Dec 8, 2009
3
0
18,510
0
I was having problems with the following setup:

Win 7 Enterprise connecting to Fedora 4 with Samba 3.0.23a-1.fc4.1 machine that had been humming along since April '04. I keep all my work/project files on this (as well as my mp3's... shhhhhh)

I have had various problems over the years depending upon windows service packs, but always been able to figure out the problems. This one was driving me nutzo however.

Most google searches will tell you the answer to the NTLMv2 options you must set, which was the problem i had been having from Vista RC1. So, i figured this would fix my latest quandary, yeah? Uhh, no.

I had recently changed my open share, or "Anonymous" SAMBA share to use Active Directory authentication (for many reasons), and that had it's own set of challenges. Once those reasons were gone, I no longer needed this to be a "secure" share.

But after removing the ADS security samba settings back to normal Anonymous settings, I had figured there would be no problem connecting, right? Grrrrr, I keep getting, "The account is not authorized to log in from this station"

After beating my head on the keyboard, I kept coming back to why other machines I "own" and operate could get to this Anonymous share, but not my own personal domain computer. I was keying on why the could map "Guest" to "Nobody"

So as soon as I "enabled" the Guest account on my local domain PC, bingo! now i can open the Anon share. But... I dont like this!

I am very skilled at securing SAMBA, but not so good at making it work in a less secure operational mode.

Can anyone help me figure out how to map SAMBA setup so that no matter who is trying to connect, they will be mapped to "Nobody" ?
 

macgruff

Distinguished
Dec 8, 2009
3
0
18,510
0
I think i might have figured this out, now that im on a roll...

edit /etc/samba/smbusers and add to the line:

nobody = guest pcguest smbguest <your domain accountname here>

just the account name, not the whole DOMAIN\accountname

Gotta reboot now and double check!
 

pastubbs

Distinguished
Dec 14, 2009
1
0
18,510
0
I too was having heaps of trouble getting windows 7 to login to Samba, it would ocasionally see the server, but most of the time it would not see it at all.
Then one day as I was edition s web page, I had a spot of inspiration, my server was called 'Sambe Server', ie with a space in the name.
Samba gave no errors, XP was happy (as well as samba on an iMac)
So I changed the space to a dash and win7 immediatly became happy!
Now if only I can get Win98 to see it.....

Paul S
 

mellephants

Distinguished
Apr 23, 2009
8
0
18,510
0


THIS


thanks!
 

derp

Distinguished
Jan 20, 2010
6
0
18,510
0



How do you do this in Home Premium? I know we're missing the Local Security Policy editor. I have read you can edit the registry to do it but I am not sure what to look for. Thanks.
 

firak

Distinguished
Mar 4, 2010
1
0
18,510
0
Hi ivdax
You say:
I have a Windows 7 machine on my test network here whenever i attempt to connect to a linux based file server on the network it kills samba on the server.

Maybe I had a similar problem. The Win7 client would not connect to the Samba domain. From this site, I did some regedit:
http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/dfd79bc1-cf36-42b7-9911-346912f4def6

Now my Win7 boxes are on the Linux net.

I have another problem. My LDAP users cant log on - yet.. :)

Firak
 

komickaze

Distinguished
Mar 10, 2010
1
0
18,510
0
I had a similar problem when trying to connect Windows 7 Home Premium and Windows 7 Ultimate to a Mac OS 10.3.9 Server. I made the following change with the Local Security Policy on Ultimate and tested it successfully while watching the registry for changes. I found the following REG_DWORD values were changed:

HKLM\System\CurrentControlSet\Control\Lsa\LmCompatibilityLevel
HKLM\System\ControlSet001\Control\Lsa\LmCompatibilityLevel

After further testing, I found these to be the values and coresponding settings:

0) Send LM & NTLM responses
1) Send LM & NTLM - use NTLMv2 session security if negotiated
2) Send NTLM response only
3) Send NTLMv2 response only
4) Send NTLMv2 response only. Refuse LM
5) Send NTLMv2 response only. Refuse LM & NTLM

I created the LmCompatibilityLevel setting on my Home Premium machine with a value of 1 (http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p=339270746) and was finally able to connect to the 10.3.9 Server.
 

Haibane

Distinguished
Mar 16, 2010
1
0
18,510
0
Little 'gotcha' I ran into -- Everything here is correct but for that SMB and CIFS both have to be enable in the Linux box firewall as well. I now have that working with Win 7/Fedora 12.

Thanks for the help, guys.
 
G

Guest

Guest
nikonz wrote :


Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options






Thank u very much for adding this post. now i can connect to my mac server.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS