Windows 7 and Samba Issue

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Status
Not open for further replies.
G

Guest

Guest
nikonz wrote :


Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options






Thank u very much for adding this post. now i can connect to my mac server.
 

pwingren

Distinguished
Apr 16, 2010
1
0
18,510
0
Anybody except me that have had problems the other way around? That is, mac snow leopard application (32 bit) failing to access data on a win 7 64 bit?

Trying to run archicad 13 bim server on a win 7. The lifted ram limit of 32 bit is great, but the mac comps running 32 bit archicad (there's no 64 bit version yet) can't see shared libraries.
 

bedfoto

Distinguished
Apr 29, 2010
5
0
18,510
0



Thanks:
This helped me start connecting to both server 2003 and Server 2000 systems when all els failed from a Win-7 pro installation from one particular computer. Funny thing is that this Win-7 (pro) had n problems connecting to other Win-7 and WinXP desktops.
 

beleek

Distinguished
May 7, 2010
1
0
18,510
0
The fix from nikonz worked very well, but I wanted to maintain some added security with these Samba networked drives and have a user and password. Now that it works how do I add this added bit of security.
 
G

Guest

Guest



thanks mate. this really worked for me too. i had hard time accessing the intra net resources on my new lappy with win7.
 
G

Guest

Guest


Thank you very much nikonz, this really helped me. i had to change my
win7 home premium to win 7 prof but still the error persisted. Cheers
 

guyr

Distinguished
May 31, 2010
2
0
18,510
0
I have tried everything in this thread (as well as everything else I can locate on the Internet) and still I cannot get Windows 7 Home Premium to connect to a Samba share on Ubuntu. I have another computer running XP Pro and it connects with no problem. On Win 7, I keeping getting access denied. Actually, I found one setting in smb.conf that does allow Win 7 to connect:

protocol = LANMAN2

But this causes more issues than it solves. With that set, *both* my XP and Win7 boxes behave very strangely (and wrongly), e.g., with the following 3 files on the Ubuntu box:

ActivePerl-5.10.1.1007-MSWin32-x86-291969.msi
ActivePython-2.6.5.12-win32-x86.msi
ActiveTcl8.6.0.0b2.291226-win32-ix86-threaded.exe

from either Win box, typing "a" or "A" and hitting the tab key just produces a beep. Typing "dir A*" lists one file and then "file not found".

So, using that protocol is not an option.

Here are the relevant options I have in smb.conf:

client lanman auth = yes
client ntlmv2 auth = yes
lanman auth = yes
ntlm auth = yes

To get my XP box to work, only the second one is required (using LmCompatibilityLevel 2). On the Win7 box, I've tried levels 1 and 2 with no difference in outcome.

I'd appreciate any other ideas. My frustration level is boiling over. Ubuntu is 10.4 x86 with Samba 3.4.7. Thanks.
 

imchipbrown

Distinguished
May 27, 2010
5
0
18,510
0
Gotta agree with you, guyr. This is not solved for me, though I have some differences. I can see the Windows 7 Home Premium (W7HP) machine from Ubuntu 8.04, as well as an XP computer. I get a Users Name/Password challenge from W7HP, and nothing works, even though I have identical username and password on the W7HP machine. If I boot into XP from the same computer, W7HP lets me right in.

Is there any way Ubuntu can identify itself to W7HP as being an XP machine?
 

shark996

Distinguished
Jun 7, 2010
1
0
18,510
0
Hi all,

I have a similar problem with Ubuntu Server and Windows Vista and Seven.

I have created a share on Samba with user and password. I opened some ports on the firewall to allow access outside.

I can see the share and mapping the disk with this command:

NET USE Z: \\publicIP\share "PASSWORD" /USER:user

The problem is that: When I'm opening a file (Excel for example) this file is always in ready only mode. With Windows XP everything works fine.

Can this fix resolve my problems?

Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options

Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption
 

guyr

Distinguished
May 31, 2010
2
0
18,510
0
My issue is solved with the help of the Samba mailing list. For those who may find this thread via search:

I had the following line in the global section of my smb.conf file:

valid users = %S

That was left over from the original smb.conf file generated by Samba upon install. I'm not using user shares, but I left it in case I might in the future. Well, that was causing my issues with Win7. As soon as I commented that out, Win7 was fine. I have no clue why XP didn't mind it.
 

Liksus2x

Distinguished
Jun 9, 2010
1
0
18,510
0
Hey all, this thread seems the closest to my issue so I thought I'd ask it here:

I'm trying to connect to my OS X 10.6.3 MacBook Pro via my Windows 7 Ultimate Laptop

They are both on the same wireless network and see each other. Additionally, they are direct connected via Ethernet cable (and both recognize as such. I did this in an attempt to speed up wireless internet especially on the PC and improve file transfer rate times.)

On the PC, I've shared some folders via "Share With".

The Mac can access (read/write) said shared folders on the PC as expected (using SMB), finding it easily on the network. No problems there.

On the Mac, I've allowed File Sharing (with SMB and AFP). I've allowed Internet Sharing. *** NOTE *** I DO have Little Snitch running. This may be an issue. I have tried to get it to accept incoming connections from "natd" which seems to be DIVERTing connections to port 2560 (labrat) of 0.0.0.0 [I have NO idea what this means). There does not seem to be any success in altering this Little Snitch rule.

HOWEVER, the issue arises when I try to access OS X via the PC. While the PC recognizes the mac on the network, it is unable to connect to any form of:

//MAC
afp://MAC
//mac.local
//MAC.local
smb://MAC.local
//mac/homefolder <--I shared the homefolder
//MAC/homefolder
//MAC.local/homefolder
//ipaddress/homefolder
etc. etc.

Giving the error(s):
Firefox can't establish a connection to the server at xxx.xxx.xxx.xxx
or
Windows can not connect to //MAC
- If I diagnose it, I receive this:
file and print sharing resource (MAC) is online but isn't responding to any connection attempts


The PC does not recognize AFP or SMB protocols (I haven't added any new software for it).

I followed the instructions by nikonz, but i saw no change.

Does anyone have any idea how to fix this or what to do? I'd greatly appreciate 2 way interaction between my machines.

Thanks a bunch!
 
G

Guest

Guest
I am currently having a problem with samba Unbuntu and Windows 7. I tried to comment out

valid users = %S

but this did not work out.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS