Windows 7 install cannot find my hard drive

Danithae

Reputable
Dec 7, 2014
1
0
4,510
0
I've been trying to install Windows 7 via DVD, but it says that it cannot find CD/DVD drivers. I've figured out that it's actually referring to the SATA drivers used for the HDD, because it cannot locate that. I've tried installing drivers from the motherboard disc, but they don't work for some reason... I've gone into UEFI and changed the drive to IDE mode, but that doesn't work either.
 


yep. it's probably referring to AHCI/RAID or IDE drivers... those drivers should be with your motherboard's install disk, you can also download them from the motherboard manufacturer's webpage. Changing the format from AHCI to IDE in the bios won't work if windows7 doesn't have generic southbridge drivers in it's install package for your motherboard. I suggest you download the drivers from the motherboards web page, unzip/uncompress them, and drop them onto a thumb drive, then attempt the windows install, load the drivers, if you do it right you should be able to chose the hard drive and particial to install your windows 7 installation.

 

RealBeast

Titan
Moderator
Windows 7 comes with generic AHCI and IDE drivers, and you only need F6 drivers for RAID. I would check that you have selected boot devices that do not include the designation as UEFI, like UEFI DVD-ROM, rather use the one just listed as DVD-ROM (or whatever designation your bios uses).

It would help if you add more information, like your motherboard model.

And yes, leave your SATA mode set to AHCI.
 


I know windows comes with generic drivers, but we don't know the hardware he has, and his problem is clearly this. i've seen this problem with laptops, as laptops often don't use generic IDE/AHCI drivers. if he's on a laptop that would explain the problem. I've also seen this problem with OLD hardware. there is old (c. 2005) hardware that won't install win7 without the manufacturers drivers.
 

RealBeast

Titan
Moderator
I agree that he could help by giving more information, but how many old boards have you seen that have UEFI? I've never seen one. It is not the only possible issue, selecting the wrong type of boot device (the UEFI type) in the boot list will also cause this problem -- seen it many times over the past couple of years.

 

pauls3743

Distinguished
Dec 24, 2011
1,836
0
20,460
272
I've seen the issue raise it's ugly head when trying to install Windows 7 from DVD using an external USB drive. At that time the only reliable work around I could find was to transfer the install files to a flash drive, make the flash drive bootable and do the install from there.
 

RealBeast

Titan
Moderator
Yes external optical drives can be an issue, and Windows 7 also does not include USB 3.0 drivers so that too can be an issue with USB -- some motherboard makers specify a couple of USB 3.0 ports that are also supported in the bios as USB 2.0. Windows 8 solved that issue by including USB 3.0 drivers, and I slipstreamed them onto a few Windows 7 install disks that will also solve that problem.

 


that is a likely issue as well. there is no native support in win7 for usb3, so if he has an external drive plugged into a usb3 slot that could be a source of the issue.

 

TRENDING THREADS