Windows 7 installation error "No device drivers were found. Make sure that the installation media..."

chrischan0323

Honorable
Jul 1, 2012
63
0
10,630
0
I recently bought the Windows 7 Home Premium Retail Version and when I tried to install its 64-bit version via DVD which it came from the physical box I bought on my PC, this was the message I got:

http://imageshack.us/photo/my-images/534/fw5r.jpg/

and then this:

http://imageshack.us/photo/my-images/818/8r3e.jpg/

My BIOS settings:
http://imageshack.us/photo/my-images/407/nc4q.jpg/
http://imageshack.us/photo/my-images/5/zkzj.jpg/
http://imageshack.us/photo/my-images/23/fn92.jpg/
http://imageshack.us/photo/my-images/845/64ee.jpg/
http://imageshack.us/photo/my-images/849/6jbv.jpg/
http://imageshack.us/photo/my-images/341/me98.jpg/
http://imageshack.us/photo/my-images/850/mije.jpg/

I just couldn't figure out what the hell was meaning of this. Somehow it worked when I tried to install its 32-bit version on my PC directly to the DVD files(not boot) but I couldn't install its 64-bit version as my currently Windows 7 is 32-bit which is not compatible with 64-bit software.

Any help is appreciated. Thanks in advance.
 

chrischan0323

Honorable
Jul 1, 2012
63
0
10,630
0


Thanks for the reply. I saw neither SATA driver in the mobo CD nor from the manufacturer's website.
As you can see:
http://imageshack.us/photo/my-images/32/ltgz.png/
http://imageshack.us/photo/my-images/541/7gth.png/
http://imageshack.us/photo/my-images/829/ybkp.png/

As for the manufacturer's website, I only found those drivers which I assume that one of them was not considered as SATA driver
http://my.msi.com/product/mb/H61M-P31--G3-.html#/?div=Driver&os=Win8%2064
 

noidea_77

Distinguished

Select "all" in the filter box and you will get the "Intel Rapid Storage Technology Floppy Driver (F6) " in the list. That's the one you need.
 

alz_solstice

Honorable
Jul 3, 2013
364
0
10,960
56
Are you upgrading from Windows Vista? I don't remember selecting drivers when installing Windows 7.

Anyway, the problem might be on your Installation Disk or with your CD/DVD Drive. Have you tried burning on a USB Drive?

Burn the files inside the Installation Disk to a USB Drive in a slower speed (recommend x8).

After burning, reboot.
Open BIOS (make sure USB Drive is plugged in)
Set USB Drive as your 1st Bootable Media
Save and Exit
Boot on USB Drive and Install Windows 7
 

Similar threads


TRENDING THREADS