Question Windows 7 Keyboard and mouse stop working on install

Jun 8, 2019
I bought parts and assembled my computer this morning but I couldn't get it to install windows 7 from my disc. It showed Windows is loading files and then the Windows logo pops up and the 4 colors start spinning to make the Windows logo and then everything goes black and the computer restarts. I finally got it to the install screen after changing to legacy boot instead of UEFI, but then it was telling me that it couldn't install on my ssd.
I did a lot of googling and never really found an answer that worked, but I changed the thing from AHCI to RAID and it installed. Everything I was reading said to have it set to AHCI, but it was on that by default, so I figured what the heck. It installed it, but then when it gets to the next setup screen where I put in the name of the computer and such, my mouse and keyboard stop working. The mouse and keyboard are plugged into usb 2.0 and I have also tried PS/2 and neither work when it gets to that screen. The keyboard is still on as I can turn the caps lock and num lock lights on and off, but nothing appears on screen when I type. Thanks in advance! Here are the specs:

Windows 7 Home Premium
ASUS Prime Z390-A LGA 1151 (300 Series)
CORSAIR Vengeance LPX 16GB (2 x 8GB)
Intel Core i7-8700 Coffee Lake 6-Core 3.2 GHz
Seasonic FOCUS Plus Series SSR-750FX 750W 80+ Gold ATX12V & EPS12V Full Modular
SanDisk SSD Plus 1TB Internal SSD
ASUS 24X DVD Burner
ASUS GeForce GT 710 2GB GDDR5
Sep 29, 2018
Ensure your keyboard and mouse are supportable for your system then

  1. Go to <advance Boot Option> disable driver signature enforcement.
  2. Delete the old drivers and install current version drivers.
  3. This problems may be occurred while using any third party services, if you are using then disable them.
  4. some setting performs in BIOS such as:
  • Legacy USB = Disabled
  • EHCI Pre-Boot Driver = Disabled
  • XHCI Pre-Boot Driver = Disabled
  • EHCI/USB 2.0 = Enabled
  • XHCI/USB 3.0 Switchable = Enabled
  • EHCI/USB 2.0 hand-off = Disabled
  • XHCI/USB 3.0 hand-off = Enabled
Ensure save all setting before exiting the BIOS

Similar threads