Windows 7 setup doesn't detect hard drive

Status
Not open for further replies.

brandontheblack

Distinguished
Jan 27, 2011
12
0
18,510
0
So my trusty old 40 GB Maxtor HDD finally died, and I'm trying to install Windows 7 on a 250 GB Western Digital Caviar SE 16 (SATA II). Windows will boot off of the DVD, load the setup, ask me if I want to perform an install or a repair, and then it asks if I want to upgrade or do a "custom" setup. I choose custom since it's a clean drive, but then it shows me a blank list of drives with the option to load a driver. My motherboard is a Gigabyte GA-G41M-ES2H, so I went to Gigabyte's website and downloaded the drivers and put them on a USB thumb drive. I spent hours trying to load different drivers to no avail. I tried the CD that came with the motherboard; no dice. I tried 32 and 64 bit installations; neither worked.

But you know what did work? My 180-day trial copy of Windows Server 2003. It detected that hard drive like Western Digital made it just for 2003.

I really don't know what to do now. I'm just barely resisting the urge to take the computer outside and smash it with a sledgehammer. Someone please help!
 

brandontheblack

Distinguished
Jan 27, 2011
12
0
18,510
0
Yes, except this:



Doesn't show my hard drive. Or any drive. It is completely blank.

EDIT: Sorry if I didn't make that clear in my first post, re-reading it, I can see that I could have worded it more clearly.
 

Combat Wombat

Distinguished
Aug 4, 2011
1,001
0
19,360
36
Not sure how he is meant to identify if it's in device manager when there is no OS installed.

When you plug the HDD into power can you here it tick over and boot up? What happens when you select driver options advanced?
 

brandontheblack

Distinguished
Jan 27, 2011
12
0
18,510
0
Yes, it powers up, and the BIOS recognizes it. As stated in the OP, Windows Server 2003 was able to recognize the drive and install fine. Which leads me to believe that this is an issue with Windows 7 not having a suitable driver for the SATA controller.

I tried loading drivers both from the disc that came with the motherboard and also from Gigabyte's website with no luck.
 

Combat Wombat

Distinguished
Aug 4, 2011
1,001
0
19,360
36
"Windows 7 not having a suitable driver for the SATA controller"

Extremely unlikely.

It could be a raid configuration change due to a update of any sort... Try resetting your bios to defaults..
 
Status
Not open for further replies.

Similar threads


TRENDING THREADS