Windows 8.1 Sleep / Shut down problem

Kasraa

Honorable
Mar 13, 2013
61
0
10,630
0
Hey guys

So it won't shutdown with "Fast startup" enabled in power options;
and it won't sleep unless I disable the Ethernet connection.
It's very annoying, and I really need this fast startup feature.
Hope there's a solution...

ASrock Z77 Extreme 4
Intel i5 3570K
2x4GB Corsair XMS3
Sapphire R9 290
ADATA SX900 128GB


- My Ethernet is connected is a D-Link wireless router.
- I also have a Creative sound card on PCI-E, if that's related...
- Did a clean Windows install.
- And I should mention, all the drivers are up to date.

Any thought would be appreciated :)
 
-fast startup keeps the system alive in RAM. You can not shutdown and keep the RAM powered on.
you can use
shutdown.exe -s -t 0
to tell the system to totally shutdown rather than go to low power state. it will not use a fast startup on the next boot in that case.

-your system will block sleep if you are sharing media thru the Ethernet. (windows media player, xbox extender,...)
start cmd.exe as a admin
powercfg.exe /energy will generate a report you can look at to see if you have a driver that is blocking sleep functions
remote clients can connect to your computer and block sleep functions also.

you can use powercfg.exe commands to override and prevent certain sources from blocking sleep. or you can go to the windows control panel, (power config or find the device in device manger and select the properties and disable some overrides of sleep funtions)





 

Kasraa

Honorable
Mar 13, 2013
61
0
10,630
0
If I'm not wrong, fast startup feature allows Windows to boot alot faster after it's turned off. (or seems it's off) So why can't I use that? I mean the display turns off and pc will be off too after a couple of minutes. Although when it boots it shows "Windows didn't shutdown properly" error. almost same thing with sleeping.

How can I find out if some media is being shared?

Can you give some tips on looking for these stuff in device manager, which one shuld I check?

Also did a report but as far as I can tell it shows nothing serious.
 
if you get the error "windows did not shutdown properly" It means your system was in a sleep state and the power was cut.
Windows 8.x with fastboot kind of redefined what it means to shutdown. It does not do a shutdown like the old windows 7 did.

-you need to make sure your system sleeps/wakes up correctly using the keyboard not the power button.

you can use control panel->hardware and sound->power options->system settings
and change what the power button is mapped to. if it is set to shutdown and you hit it will power off a sleeping system
rather than wake it up. This will generate the error you got. Set it to do nothing and use your keyboard or mouse to wake the system.
or keep it on shutdown and only really hit the button if you want to kill power. Don't use the button to try to wake the machine because it will force a total power down on a sleeping system. (not the same as a windows shutdown)

The level of "sleep" your system supports will depend on the hardware and the drivers your system has. Newer hardware supports more low power states than older hardware.

you might try
powercfg.exe /requests

this command will give you a list of .exe that hold request on the sleep scheduler. It will be a list of currently running apps that have the right to block sleep requests.

I just ran it on my windows 10 machine and I have one device that is currently running that windows has to ask for permission before it can put the system to sleep. In my case it is some streaming audio.

run the command and see if there are any apps running that can block sleep. (windows media player might be one if you have it running)


shared media:
control panel -> network and internet
anything that is shared for public use can block.

check to see if you have a shared printer that is plugged into your machine.
check to see if you have photos, music, or videos being shared out.

you might also want to go to:
control panel->hardware and sound->power options->edit plan settings
change advanced power settings
find multimedia settings, when sharing media and select "allow the computer to sleep"
(look at the list, I have windows 10 so I can not check the settings for window 8, they might have changed)

last time my wifes machine had a sleep problem it was because she connected a printer to it directly and it was being shared out. This prevented her machine from going to sleep even though her machine was the only one that had access to the printer.
I disconnected her machine from the printer, disabled the printer sharing. put the Printer on a wireless network and had the router give it a IP address and her machine would sleep correctly again.






 

Kasraa

Honorable
Mar 13, 2013
61
0
10,630
0
The problem isn't not sleeping in idle states...It's just when I click "Sleep" it just turns off the monitor and after about 10 minutes whole PC turns off and nothing works. After powering it on with the power button, it boots from scratch and gives the error.
The error is like this:
http://www.computerandyou.net/wp-content/uploads/2013/03/Windows-8-Retstart-issue-2.jpeg
sorry for not being clear before.

Checked the requests, nothing.

And nothing is shared. I have removed Homegroup and have disabled all the file and printer sharing options for all users just to make sure.

Also sleeping while media is being played is allowd.
 
let me know if we are talking about the same issues now.

so if I got this right: you have two issues:
why does it take 10 min to put the system to sleep when it should only take less than 30 seconds
and 2, why will it not wake up from sleep?

===================

on my machine:

event
1. i select sleep
2. 2 seconds later the monitor turns off
3. 30 seconds after that the CPU and case fan turn off
4. I hit the space bar
5. 2 seconds later the monitor is on and I can start typing.


so in your case: 1 and 2 are the same, number 3 happens but takes 10 minutes
and you can not wake the machine with the space bar?



So the question would be why is it taking 10 minutes to turn off the system/cpu fan
and why can you not wake the system with the space bar?


----------------------
I would check the sleep setting:

in your control panel power options setting, advanced settings tab, look in the sleep section, expand allow hybrid sleep
and check to see that it is on.

now when your system goes to sleep it will be in the correct state.

I think your system is sleeping, I think is taking too long to sleep and is not waking up.

First question would be what kind of keyboard do you have connected. (usb or ps/2 type)

then I would check the BIOS to confirm that your BIOS power management does not completely power down the USB ports/hub
then I would also check the BIOS to make sure it is set to wake via keyboard space key.

if you find that the computer fans do turn on when you hit the space key but the screen does not come on. Then look for a BIOS setting that
says something like repost vga after s3. the newer monitors also have sleep circuits that turn the monitor off after a timeout period. It is set in the monitors firmware. Some monitors will not turn back on until they see a signal from the computer on the video line. The bios setting will send that signal.
otherwise you might have to unplug and plug in the monitor video cable to get the monitor to wake up.
 

Kasraa

Honorable
Mar 13, 2013
61
0
10,630
0
Yes you got it right about those two issues.

Hybrid sleep is already on.

I have USB keyboard.

No the fans wont wake. It's just like shutdown.

OK I just checked something, did a clean boot (unchecked any non-Microsoft services and all startup applications from msconfig.exe) and now when I disable Ethernet, sleeping works just fine as it used to in Win 7 (or the way you mentioned). but ONLY when I disable Ethernet.
So now we can be sure about keyboard - BIOS - monitor; and focus more on why Ethernet connection and apps cause this.

And thanks for your thorough answers.
 
generally, if a ethernet keeps a system awake it will be a shared device blocking the sleep request. This would be detected by the powercfg.exe /requests
but the ethernet driver itself can do this at a lower level, if the driver is set to WOL (Wake on LAN) but is not requiring a Magic Packet to wake up.
This would mean that any LAN activity to the ethernet driver would wake up the machine.

so you would update your ethernet driver, then start start control panel-> device manager locate your network adapters, right click on the adapter name,
bring up properties, go to the power management tab.

the listings will depend on the where you get the driver from. if you want to do remote management on the computer while it is asleep, then select "only allow a magic packet to wake the computer"

if you don't want anything to wake the computer via the network. uncheck "allow this device to wake the computer"
(it will keep devices like a xbox from waking your computer through a extender program if you use your computer to store movies or stream to your xbox)
you want to update the ethernet device driver because of various potential bugs.
also the drivers that you get from Microsoft will be generic stripped down drivers, the drivers you get from the OEM (not the motherboard manufacture) will be the most current with the most working options)
so you would look at your motherboard specs, find the name of the ethernet driver chip, then go the the manufacture of the chips website and down load their driver.
for broadcom http://www.broadcom.com/support/ethernet_nic/downloaddrivers.php (look in your spec to figure which chip you have)



 

Kasraa

Honorable
Mar 13, 2013
61
0
10,630
0
Successfully updated Ethernet chipset driver downloaded from Broadcom website and unchecked "Allow this device to wake the computer" but didn't work...

I'm about to lose hope but I really need this sleeping thing :(
 
well you have to check something.
windows does not always put the driver you just installed as the current driver for a device.

(for example my system has 9 drivers for my one intel card. you have to go and tell the system which one you actually want to run after you install.)

So start control panel, device manager, find the ethernet driver, look at the properties, in the driver tab. check the driver provider name and driver date and version
and confirm the one you just installed is in use. Not the old generic driver that micorsoft windows provided.

if the wrong one is selected, right mouse click on the adapter, select update driver software.
select browse my computer for driver software (locate and install driver software manually)
now select "let me pick from a list of device drivers on my computer"

and it should come up with a list of driver.

THen you get pissed off because you have a list of 9 driver with no version number or file dates listed in the UI but each one is actually a different file.
and differnet driver.

I have a list that looks like this:

Intel(R)Ethernet Server Adapter I350-T2
Intel(R)Ethernet Server Adapter I350-T2
Intel(R)Ethernet Server Adapter I350-T2
Intel(R)Ethernet Server Adapter I350-T2
Intel(R)Ethernet Server Adapter I350-T2
Intel(R)Ethernet Server Adapter I350-T2
Intel(R)Ethernet Server Adapter I350-T2

and each one is actually a different version and different build
(and I want to beat the person who wrote the code for this setup.)

You can pick one and hope you get the correct one, and verify by the driver date and version or you can end up and use the PNPutil.exe and remove the old driver versions so you have a shorter list.

This is often the cause of when people say a new driver did not help.
(the old driver is still being used)

I often turn to looking at memory dumps to confirm the correct drivers are being used.
or you can use the driverquery.exe command to confirm.
or remove the old driver packages via pnputil.exe command.

so confirm you have the correct driver installed, and I will think about what could also be another cause of this problem.

peer to peer communication via the network would be the next cause I would look at.


but you need to make sure your driver does not have any wake on LAN enabled
it might be called (WOL) if it is enabled and no magic packet is required your machine will keep awake if there are other machines on the same network segment.

The machines talk to each other, they keep a list of resources available on your network and they vote as to which machine keeps the master list. This talking can prevent your machine from going to sleep when your Ethernet is plugged in.
Often your machine will only sleep if the other machines are off or also sleeping.





 

Kasraa

Honorable
Mar 13, 2013
61
0
10,630
0
Well I did all of this while installing the driver. It's the exact version I manually downloaded.

And the only option checked in Power Management tab is: "Allow the computer to turn off this device to save power".

Actually this is my whole Network adapters segment:
http://www.imageupload.co.uk/images/2014/10/23/na.jpg

The other two are for my WiMAX modem and a VPN client.
BTW uninstalling those changed nothing.
 
ok, maybe plug your Ethernet cable directly into the cable modem so you can be sure no other devices are talking to the Ethernet card and see if you can put the system to sleep.

( just in case the wireless side of your router is routing traffic to the wired side of your router and then to your wired Ethernet card and that traffic kept your wired LAN card from sleeping) ( AP isolation setting in the router)
I guess a wireless printer could to it also



 

Kasraa

Honorable
Mar 13, 2013
61
0
10,630
0
Well the problems are solved!
The only software I can't live without was causing all of this: Netlimiter!
Seems like disabling both it's startup and service wasn't enough. I was checking the Ethernet properties for unnecessary items, unchecked "NetLimiter Ndis Driver" and no more problems. "Fast startup" feature is also working perfectly and surprisingly fast.
I'm sure those sharing stuff you mentioned were blocking the sleep as well so I'll pick it as the solution.

I have to find a substitute for this Netlimiter as I strongly need a network bandwidth management software. or if someone can suggest a good one, it'll be great. Although I wish there was a way to keep Netlimiter.

And thanks dear johnbl for such amazing clues.

Good day
 

AspenQn

Reputable
Mar 9, 2015
1
0
4,510
0


I ran the powercfg.exe /energy and received notification of errors but cannot figure out to access the report it generated a C:\Windows\system32\energy-report.html. I can find this in Windows but nothing is there when I try to open it. I have a screenschoot of the error message but don't know how to post it here.
 
You don't have rights to edit a file in this location. Copy the file to a new location, then open it.



 

ASK THE COMMUNITY

TRENDING THREADS